I am using Windows 7 on an Acer Aspire 5755G laptop. How can I disable my laptop keyboard without disabling the wireless external keyboard?

(I guess I am looking for the Windows 7 equivalent of this AskUbuntu question.)

| |
  • 2
    Do you want to permanently disable it, or do you want the option to turn it off and on regularly? – Christopher N. Boisjoli Feb 15 '14 at 3:57
  • 1
    @ChristopherN.Boisjoli I'm not the OP, but I have the same question, and I'm looking to turn it on/off regularly - don't mind if this requires a restart – lofidevops Jul 14 '14 at 8:42
  • Try disabling via device manager? – Samuel Nicholson Jul 18 '14 at 10:40

The "Disable" option was not available to me, and attempting an uninstall required me to restart, which promptly reinstalled the driver!

These results helped me find more search terms, which led me to a suggestion by Tiga (on another site) to deliberately use an incompatible driver:

  • Open Device Manager
  • Select "Update Driver"
  • If prompted to check online or use existing drivers, choose existing drivers only
  • Display incompatible drivers (or de-select "Only use compatible drivers")
  • Choose one
  • Restart
  • Keyboard is now disabled (and in my case, touchpad too, which I'm fine with)

To restore the keyboard:

  • Choose the compatible driver
  • Restart
| |
  • 1
    This saved my life, I couldn't do anything with my onboard keyboard because of a juice spill, +1 – yoda Dec 7 '14 at 17:19
  • But I need the touchpad, what is the solution? – TSR Jul 11 '17 at 16:06

Open Device Manager in your laptop.
Expand the Keyboards section.

You might be seeing this (if you have not yet connected the external keyboard) :-

enter image description here

The keyboard arrow marked in red is the inbuilt keyboard your laptop has. (Your laptop's keyboard might have a different name)

Now connect your wireless keyboard.
You will see another keyboard added under the keyboards section in device manager (arrow marked in green).

wireless keyboard

Again, your wireless keyboard would have a different name than mine (mine is wired). This is just an example.

Now right click on the inbuilt keyboard and click 'uninstall' (marked with red arrow).This will disable your inbuilt keyboard.
Do not panic as the inbuilt keyboard's drivers would be reinstalled as soon as you restart the machine. However, uninstall the inbuilt one only after you have plugged in your wireless one.

| |
  • 2
    your answer didn't work for me, but it led me in the right direction and I appreciated the detail in your answer, so I've awarded you the bounty – lofidevops Jul 26 '14 at 9:09
  • The laptop keyboard still functions after uninstalling the driver – Matthew Lock Jun 5 '16 at 1:50

Samuel Nicholson is correct. You should see 2 Keyboards in your device manager under the keyboard category when you have the wireless keyboard connected. You can right click on Computer/My Computer and choose Manage to get there quickly.

Right click on the keyboard that is not wireless/bluetooth and disable should be an option.

| |
  • your answer didn't work for me, but it did lead me in the right direction, thanks – lofidevops Jul 26 '14 at 9:10
  • there is no disable option on keyboards – Matthew Lock Jun 5 '16 at 1:50

Download Sysinternals Suite from Microsoft (https://technet.microsoft.com/en-us/sysinternals/bb842062). After installing the Suite, go to the Sysinternals folder and launch 'autoruns.exe' . When autoruns.exe opens click on the 'Drivers' tab. From there you can do [Ctrl]+F (find) and type i8042prt.sys or scroll down until you find i8042prt.sys . Once you find it, uncheck its corresponding check box and restart your computer.

| |

Not the answer you're looking for? Browse other questions tagged or ask your own question.