I recently purchased a 64gb usb thumb drive, but for some reason it appears as two disks on every system I've insert it in. I've tried to repartition it in Linux, Windows, and MacOS to no avail. Here's the dmesg when I insert it in a linux box:

usb 1-6: USB disconnect, address 4
usb 1-5: new high speed USB device using ehci_hcd and address 5
usb 1-5: New USB device found, idVendor=1307, idProduct=0165
usb 1-5: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 1-5: Product: USB Mass Storage Device
usb 1-5: Manufacturer: USBest Technology
usb 1-5: SerialNumber: 09090388b7b0a7
usb 1-5: configuration #1 chosen from 1 choice
scsi5 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 5
usb-storage: waiting for device to settle before scanning
usb-storage: device scan complete
scsi 5:0:0:0: Direct-Access                               0.00 PQ: 0 ANSI: 2
scsi 5:0:0:1: Direct-Access                               0.00 PQ: 0 ANSI: 2
sd 5:0:0:0: Attached scsi generic sg4 type 0
sd 5:0:0:1: Attached scsi generic sg5 type 0
sd 5:0:0:0: [sdc] 61440000 512-byte hardware sectors: (31.4 GB/29.2 GiB)
sd 5:0:0:0: [sdc] Write Protect is off
sd 5:0:0:0: [sdc] Mode Sense: 00 00 00 00
sd 5:0:0:0: [sdc] Assuming drive cache: write through
sd 5:0:0:1: [sdd] 63995904 512-byte hardware sectors: (32.7 GB/30.5 GiB)
sd 5:0:0:1: [sdd] Write Protect is off
sd 5:0:0:1: [sdd] Mode Sense: 00 00 00 00
sd 5:0:0:1: [sdd] Assuming drive cache: write through
sd 5:0:0:0: [sdc] Assuming drive cache: write through
sd 5:0:0:0: [sdc] Attached SCSI removable disk
sd 5:0:0:1: [sdd] Assuming drive cache: write through
sd 5:0:0:1: [sdd] Attached SCSI removable disk

Can somebody tell me how I can re-partition this thing to appear as a single drive? I've had no luck with any of the partition utilities on any OS because this drive doesn't appear as one disk with two partitions, but two physical disks.

The drive is a Centon ElitePlus. I'm beginning to think that something is physically wrong with this drive. Can anyone confirm?

  • What brand of USB drive is it? – matpie Nov 17 '09 at 17:25
  • whats the size of each partition ? – user8228 Nov 17 '09 at 17:30
  • @revolter: sdc is a 31.4GB drive, sdd is a 32.7GB drive – quack quixote Nov 17 '09 at 17:59
  • is there any utility provided with the Flash Disk ? – user8228 Nov 17 '09 at 18:39
  • no software is provided, and this disk is not advertised to have any special features. – bmdhacks Nov 17 '09 at 19:41

Here is the explanation directly from Centon:

Question: I recently purchased one of your 64GB DataStick flash drives, and I was surprised to find that the 64GB device was formatted with two partitions. Why is this? Can it be re-configured?

Answer: Due to a limitation in Windows 2000/XP/2003 computers, drive volumes cannot be formatted in capacities larger than 32GB using the FAT32 file system. As a result, to ensure the drive can be recognized by the most number of computer systems, our 64GB drive is partitioned into two 32GB volumes. The Windows formatted capacity is roughly around 30GB.

When the 64GB drive is connected to your Windows computer, it will be assigned two drive letters.

The drive cannot be reconfigured into a single 64GB partion. The partition on these drives is hardcoded into the USB-to-flash controller chip.

So no, your drive is not faulty. They decided that the best thing for you, the consumer, is to actually use two seperate drives. I would be mad if I ordered a USB drive and realized that the manufacturer created this restriction without any mention on the product description page.

  • 1
    I'd guess that the drive is implemented as two 32GB drives that can't be combined. It's probably cheaper that way. Separate "partitions" is a good excuse, as long as you're not a sophisticated user. – Auxonic Nov 17 '09 at 20:02
  • I was thinking the same thing. They probably tried to keep the price as low as possible and chaining together two 32GB drives was the cheapest. – Marcin Nov 17 '09 at 20:10
  • Thanks for tracking this down, I was unable to find it through my google attempts. Yeah, I'm pissed alright. – bmdhacks Nov 17 '09 at 23:52
  • 2
    The actual reason is of course that the manufacturer didn't have access to (sufficiently cheap) 64GB chips, and in stead put in two smaller ones. Then they saved money by adding a simple usb switch rather than doing the <i>right thing</i> and sticking in a raid controller. The partitions excuse would only work if the drive had two partitions on a single logical drive, rather than having the partitions on separate logical drives. – Eroen Dec 11 '11 at 20:16
  • The information here is false, anyways. Sure, you can't format a drive above 32GB on those systems. But they will read a drive that has already been so formatted. – trlkly Oct 2 '14 at 12:38

It doesn't appear to be two partitions, it appears as two separate drives. If it were two partitions on a single drive, you'd see device names like sdc1 and sdc2.

It's likely the drive is implemented as two physical drives at the hardware layer, and depends on a special driver to allow the OS to see it as a single drive. It may also be a chipset limitation (in whatever chipset is used in the thumbdrive hardware).

Either way, it doesn't seem likely that you'll be able to force it to be seen as a single drive. If you require this functionality, return the device for a refund and buy a different device.

  • 1
    They probably have implemented it as a single USB device but with two different LUNs, which, for the operating system is as good as two different drives (only that there are not concurrent reads/writes possible, they have to be serialized) Under Linux you could use LDM to chain the two partitions together to one JBOD device, though. – Ro-ee Aug 4 '17 at 23:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.