0

I can read from a remote server using

sudo mount //Bor****ges/imgdisk4 /home/ilan/remoteDisks/biMnt -o user=,pass=

There is something similar for the Mac, which also can't write, but I want to concentrate on Linux for the moment. I thought perhaps the server itself isn't giving me write permission, so I used a Windows machine. Under Windows I have no problems writing, so the server itself isn't blocking me.

In an answer in superuser I found this

sudo mount -o umask=0,uid=nobody,gid=nobody /dev/something /mnt/somewhere

I tried adding -o umask=0,user=,pass=, but it complained that the syntax was incorrect. I went to the man page for mount and found the correct syntax was -w, which is the default. If it is the default I should have always been able to write. In any case, I removed umask=0 and added -w. The result, not surprisingly, was that I still can't write to the network drive.

Can anyone tell me where the problem lies and what I need to do to solve it?

Thanks, Ilan

  • With my original command, a mount command with no arguments gives://Bor*ges/imgdisk4 on /home/ilan/remoteDisks/biMnt type cifs (rw). According to this I should have read write permission, but I don't. – Ilan Tal Feb 16 '14 at 7:16
  • Try setting uid and gid to the user / group ID that you want to grant access. Additionally, for Samba mounts it might be better to use smbmount instead of directly calling mount – michel-slm Feb 16 '14 at 7:20
  • It is telling me I have a syntax error. I tried umask=000 but that didn't help. I need to specify my user name and pw to get onto the server. Maybe that doesn't work with umask=000? The error is:mount error(22): Invalid argument Refer to the mount.cifs(8) manual page (e.g. man mount.cifs) – Ilan Tal Feb 16 '14 at 7:40
  • I tried smbmount long ago. I no longer remember what the problem was, but eventually I went to mount. The strange thing is that mount with no arguments says I have rw permission. – Ilan Tal Feb 16 '14 at 7:42
0

I am posting the answer I found in the hopes that it might help somebody else.

My machine is Ubuntu 13.10 and I have Windows XP running in a virtual box. From XP I could write to the server so that I knew the server itself had no objections.

Going into the man mount.cifs I found there was an option to turn off the client side permissions checking. It was clearly stated that the server itself could still veto the write, but from XP I knew that the server would not object. I specifically requested the rw option, which may not be necessary since it is the default. The crucial part was the noperm option. The command which works is:

sudo mount //Bor*ges/imgdisk4 /home/ilan/remoteDisks/biMnt -o rw,noperm,user=,pass=

After getting Linux up and running, I also managed to the Mac going as well. The Mac was easier in that it only involved setting the rw flag.

Ilan

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.