I have a Windows 8.1 computer that is stock - almost no settings have been changed. I want IPv6 Connectivity via Teredo; however, it does not work.

  1. ipconfig shows a Teredo IPv6 address (2001:0:9d38:so:on:and:so:forth)
  2. My firewall (linux) sends out the Teredo UDP packets - which I ping an IPv6 address I see them exit my router on eth1
  3. No packets come back in response
  4. My firewall logs shows no packets block/dropped from the IPv4 address the Teredo packets are sent to

I'm not quite sure what the problem is - although I didn't sign up for a Teredo service. Does Microsoft run one for it's users? Could it be down or discontinued?

  • Teredo is quite possibly the most unreliable method you could possibly have chosen. Please don't even attempt to go any further with this, if you value your sanity. – Michael Hampton Feb 17 '14 at 4:19
  • Which is ironic, because the reason I'm trying to get it to work is for Remote Assistance Easy connect, which should be as simple and user-proof as possible. – Tom Ritter Feb 17 '14 at 13:09
  • What does IPv6 have to do with remote assistance? Didn't Microsoft already figure out how to punch that through NAT? – Michael Hampton Feb 17 '14 at 14:33
  • According to messengergeek.wordpress.com/2012/02/07/… Remote Assistance Easy Connect uses IPv6 – Tom Ritter Feb 17 '14 at 17:56
  • 1
    Aha, so PNRP is an IPv6-only protocol. Nice work. I suppose at the time, using Teredo when only native IPv4 was available was a reasonable decision, but it just hasn't worked out in practice as well as its proponents claimed. It doesn't punch through NAT nearly as well as expected, and you also are relying on a completely unknown Teredo relay, which may not even exist. I suggest you just get a tunnel from SixXS or HE. – Michael Hampton Feb 17 '14 at 18:02

It seems like Michael was right - and although Windows 'supports Teredo out of the box' whoever is on the other end of that tunnel doesn't support Microsoft.

After signing up for a tunnel with HE, and running their configuration commands, it worked instantly and Remote Assistance Easy Connect was also able to connect.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.