0

I have Ubuntu 12.04 running plex media server Version 0.9.8.18.290-11b7fdd.

Everything looks like it is working but when I go to stream a video it takes a very long time before it starts (20 mins or so).

Once the video starts it buffers multiple times a second making it impossible to watch.

I have tried reinstalling plex but this does not help.

I ran strace on start_pms and it shows the transcoding session start

!!! Plex Transcoder v3.003.13.0403-0054 (c97b73a, DEBUG, x86_64) !!!   "/usr/lib/plexmediaserver/Resources/Plex New Transcoder"  "-i"  "http://127.0.0.1:324...arts/2/file.mp4"  "-threads"  "0"  "-y"  "-segment_format"  "mpegts"  "-f"  "segment"  "-loglevel"  "quiet"  "-loglevel_plex"  "error"  "-map_metadata"  "-1"  "-progressurl"  "http://127.0.0.1:32400/video/:/transcode/session/57yq5y9qis8/progress" "-vcodec"  "copy"  "-flags"  "-global_header"  "-segment_time"  "10"  "-segment_start_number"  "0"  "-bsf"  "h264_mp4toannexb"  "-map"  "0:0"  "-sn"  "-acodec"  "libmp3lame"  "-aq"  "2"  "-map"  "0:1"  "media-%05d.ts"
----------------------------------------------------------------------------
    Disable Segmenter (only one output destination allowed)

In another terminal i ran ps aux |grep "Plex New Transcoder" there isn't a transcoder process running.

At the beginning of the strace there are some errors about files not existing

access("/etc/ld.so.nohwcap", F_OK)      = -1 ENOENT (No such file or directory)
mmap(NULL, 8192, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7ff5b8bab000
access("/etc/ld.so.preload", R_OK)      = -1 ENOENT (No such file or directory)
open("/etc/ld.so.cache", O_RDONLY|O_CLOEXEC) = 3
fstat(3, {st_mode=S_IFREG|0644, st_size=31607, ...}) = 0
mmap(NULL, 31607, PROT_READ, MAP_PRIVATE, 3, 0) = 0x7ff5b8ba3000
close(3)                                = 0
access("/etc/ld.so.nohwcap", F_OK)      = -1 ENOENT (No such file or directory)

The server has a quad xeon processor and 16GB of ram so there shouldn't be any problem running plex.

0

sudo service ufw stop

would be the first place I'd start (it disables the fw on ubuntu, which is enabled by default. If that improves things you need to tweak your iptables.

See this:

https://forums.plex.tv/index.php/topic/33751-problems-with-pms-and-ufw-on-ubuntu/

| improve this answer | |
  • iptables are not running for testing purposes and ufw stop doesn't help. It looks like the plex transcoder is going dead immediately after starting so it doesn't have more than 5 seconds of video to play . – Ripster Feb 17 '14 at 2:02
  • Also strace isn't going to tell you much, get a tcpdump of the traffic from your plex client is a lot more helpful. The files not existing are a red herring, the the presence of ld.so.nohwcap just tells the dynamic linker to use a non-optimized library. – quadruplebucky Feb 17 '14 at 2:06
  • Does the source file play cleanly in say, VLC? – quadruplebucky Feb 17 '14 at 2:14
  • The source plays in VLC just fine. I just tested a file that doesn't have to be transcoded and it works fine. The issue seems to be with the transcoder. – Ripster Feb 17 '14 at 2:30
  • I dunno. I suppose I'd try downgrading, but the history of plex transcoder issues on linux isn't very encouraging anyway. Just for kicks have you tried the 32 bit version? – quadruplebucky Feb 17 '14 at 3:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.