I have a HP Ultraslim docking station for my HP Elitebook Folio 9470m ultrabook. The connection to the external monitor and the network works fine - but I cannot seem to plug in any peripherals into the USB ports on the docking station

  • external keyboard attached to any of the USB ports isn't recognized - no typing works
  • external harddisk connected to the single USB port with power supply isn't recognzied

The peripherals work just fine when I plug them directly into the ultrabook - but that kinda defeats the purpose of having a docking station!

Any ideas? Thoughts? Similar experiences? Anything I can check, set, configure to make those USB ports recognize my peripherals?

  • 2
    Silly question, but is the docking station connected to the power? – Michael Frank Feb 18 '14 at 9:58
  • Sounds like the docking station isn't 'informing' the computer to use the external keyboard... Is the docking station up to date? – Dave Feb 18 '14 at 10:03
  • @MichaelFrank: yes it is - and the video signal shows up on the external monitor, and the ethernet network connection works just fine – marc_s Feb 18 '14 at 10:34
  • @marc_s you'll find that many docking stations will still happily send through video signals and network connections without any power supplied to them. I've run into this issue before, just needed to ask. – Michael Frank Feb 18 '14 at 11:04
  • @MichaelFrank: ah - ok - wasn't aware of that. But the docking station is definitely powered on in my case. – marc_s Feb 18 '14 at 11:25

Remove the laptop, turn off the docking station.

Now, plug in the keyboard/mouse etc

Now turn on the docking station, give it a little time, and now put on your machine. It appears many docking stations need to work in a certain order, it doesn't detect the keyboard/mouse (I guess in the same way a PC doesn't detect a PS2 mouse/keyboard without a reboot).

Some have reported that, "disable one of the two USB Root Hub from the Device Manager and refresh the list allowing the system to recognize the connected devices". Source

Others have claimed to roll back the driver to a generic driver Source

Based upon your comments, since it doesn't recognize multiple devices (keyboards/external disks) then it sounds faulty. You could ask HP for advice directly, if it's in warranty then it's a no brainer (send it back) but you may need to get a new dock :( However, to test this, try a different laptop in the dock (if possible).

  • Dave: I tried this - no luck, no improvement. Situation is still the same - trying to connect the keyboard to the docking station results in a "dead" keyboard - no typing is being sent to the notebook :-( – marc_s Feb 18 '14 at 21:42
  • Sorry @marc_s, for some reason your comment did reach my inbox. Did you try a different keyboard (just for testing purposes, I don't have much hope it will help, but it's easy to try) – Dave Feb 21 '14 at 8:46
  • @marc_s I think the only option you have is to contact HP and see what they suggest? Sounds like it's a faulty dock... – Dave Feb 27 '14 at 10:26
  • Dave - yes, I tried several keyboards, several external disks - all show the same behavior (not being "recognized" or "accepted" by the dock). – marc_s Feb 27 '14 at 10:27
  • 1
    I'm sorry @marc_s, I've continued to look into this for you (to say thank you for giving so much to community at SO), I think this has to be going back to HP, I've found nothing to help. – Dave Apr 24 '14 at 7:12

There are several of us in our office that have Folio 9470m/ultraslim docking stations. I know of at least two who have the same usb problem. What I found that worked was to pull the power cord out of the docking station for about 10 seconds, plug it back in and miracle of all miracles, it works. So that is the workaround I use. Lame but until HP comes up with a fix, I'm not sure what else to do.


My docking station worked fine, but I needed my IT Department to re-image my laptop for an unrelated issue. When I got my laptop back, the USB ports were not connecting. It was driver based. With the laptop docked, go into device manager and update all your USB drivers. I updated the drivers and everything is now working perfectly.


I experienced this same issue -- dock was powered, but keyboard and mouse were not recognized. This worked for me: In your list of programs see if you have an Intel USB 3.0 eXtensible host controller (or any other USB host controller that may be preventing your laptop from recognizing the dock's usb ports). I removed it and my mouse lit up!


After I realized I plugged my power into the laptop instead of the docking station, I did the following:

  1. Undock the laptop, power off docking station and re-connect mouse and keyboard - just plugged into different USB sockets.

  2. Power on docking station, wait for 10-15 seconds with that back light on and then plugged in laptop.

Once screens lit up there was a message that USB devices were installed.

Weird thing is that the charger for my phone worked on any USB ports on docking station but mouse and keyboard did not recognize. They both worked when plugged into laptop directly.

On side notes, my docking station has 2 HDMIs and it supports two external monitors that way + analog one. Don't have a fourth monitor but guessing the HDMI port on laptop itself would support it.


remove Ultrabook from dockingstation, connect USB dongle (wireless keyboard/mouse), redock and - wow! - works! Strange design


Even the keyboard doesn't work, so I suspect it is faulty. I had a power problem with an EliteBook 850 G1 on the 2013 UltraSlim Dock. Long story short, the dock power supply isn't supplying enough amps. I used an older HP power supply capable of supplying more amps, and everything works consistently. The older docks used to come with a higher amp capacity, so I reused one to solve my issue. I would not think keyboard and mouse would be an issue, but if a higher capacity power supply is available to you, try it, but I suspect something is up with that dock.


Upon inspection of my laptop, I saw that the driver for the USB ports on the docking station was not installed.

Follow the steps below to install the driver; or at least validate the USB driver is installed.

  1. Open Control Panel
  2. Open Device Manager
  3. Scroll to Bottom "Universal Serial Buss Controller" (USB)
  4. Expand Tab
  5. Install driver, or verify if driver is installed

I had identical symptoms on an Elitebook 840 G3. I went to device manager and opened the USB drivers. All said they were working ok except the last one which was "USB Composite Device". I tried to install the driver but my win7 Pro told me it was up-to-date. However it still said it was not installed, so I deleted it and rebooted (while attached to the dock - which probably made no difference). It then installed itself and the USB ports on the dock now work

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.