Cannot correct the following conditions. XP Home SP3. I have tried just about everything ... chkdsk /f, chkdsk /r, chkdsk /P, chkdsk /v .. using XP recovery console where needed. Have spend several days ... probably rebooted 100 times with one attempt or another. Would really appreciate help with a solution. Thank you in advance.

C:\Documents and Settings\Owner>chkdsk

The type of the file system is NTFS.

WARNING! F parameter not specified. Running CHKDSK in read-only mode.

CHKDSK is verifying files (stage 1 of 3)... File verification completed. CHKDSK is verifying indexes (stage 2 of 3)... Deleting index entry WS54B9~1 in index $I30 of file 51674. Deleting index entry wssCALZIS3P in index $I30 of file 51674. Index verification completed.

Errors found. CHKDSK cannot continue in read-only mode.

| improve this question | | | | |
  • well how about if while in recovery console you do an option that corrects errors.. whatever switch that is. (I know the recovery console chkdsk has different switches to the regular). Does it still say read-only when you do a switch that fixes errors? Regarding "WARNING! F parameter not specified. Running CHKDSK in read-only mode." a technet article says technet.microsoft.com/en-us/library/cc730714.aspx "If you run chkdsk without the /f parameter on an active partition, it might report spurious errors because it cannot lock the drive. " So paste what happens when you do chkdsk /f – barlop Feb 19 '14 at 0:57
  • -1 Your own output says to do the /F So you should have included the output when you did /F. Did it say it requires a restart? Did chkdsk then run and if not what error did it give and if so then what error did it give? – barlop Feb 19 '14 at 7:59

Try to set the "dirty" bit of your drive and see if after restarting, autochk executes chkdsk.

To query the current status of the dirty bit, type:

fsutil dirty query C:

To set the dirty bit, type:

fsutil dirty set C:

Hope that helps!

| improve this answer | | | | |
  • can you explain how that would help him? would that just cause chkdsk to run automatically? how would that help more than running it manually? and if it's down to the switches it runs when it runs automatically, do you know what switches they are? but also note that he could run it manually – barlop Feb 19 '14 at 0:59
  • Running it manually is not working, as explained in the question. Setting the dirty bit allows chkdsk to run without the hindrance of unnecessary services/programs. And the KB you mentioned says that running it on an active partition won't work. We avoid this with autochk. – JSanchez Feb 19 '14 at 1:17
  • I wonder if doing /F will do that anyway? i've often run chkdsk and it said it needs to restart to run. (of course, he hasn't told us what happened when he did /F). – barlop Feb 19 '14 at 8:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.