1

I have the following network diagram, using VMWare Fusion 6 Network Diagram

I am able to ping from the en0 interface on my mac to all of the 172.16 network, and on the custom linux kernel (2.6.x) base I can ping the NAT server and the host side nic but I can't ping the 192 network. The Nat isn't translating to the 192 network. I thought maybe since 192 is a private network that it won't translate but it doesn't work with any network on the other side.

I also tried to put the VM on a host only network and add a route to the 192 network manually, and it still failed to work (VM to host).

Any help would be appreciated.

  • Is there a reason you're using two different subnets? If you bridge your NIC, the guest would be on the same network as the Mac and you'd be able to communicate fluidly. – CIA Feb 19 '14 at 4:10
  • I can't use the bridge network, I need to have the vm a statically assigned ip address, and I can't statically assign it on the 192 network not an admin. – Greg Brown Feb 19 '14 at 4:23
  • Are you trying to NAT a service? Or trying to allow a route from 172.16.0.0/16 to 192.168.1.0/24? – CIA Feb 19 '14 at 4:32
  • I want to route from the 172 net to the 192 net, I can't bridge the vm to be on the 192 net. Is there a work around where I can put it as a host only vmnetwork and still connect to the external net, without using NAT. NAT is what is failing right now. – Greg Brown Feb 19 '14 at 4:47
  • If you don't need NAT, then the solution is simple; build a route. See my answer below. – CIA Feb 19 '14 at 4:49
1

Verify a route exists on your linux box for 192.168.1.0/24:

netstat -rn

You'd be looking for something like:

Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.1.0     172.16.225.1    255.255.255.0   U     0      0        0 eth0
0.0.0.0         172.16.225.4     0.0.0.0         UG    0      0        0 eth0

If you don't have a route for 192.168.1.0/24 you can add it manually.

Example:

route add 192.168.1.0 subnet 255.255.255.0 gateway 172.16.225.1

This means any traffic headed for 192.168.1.0/24 from your linux box, would route to 172.16.225.1, and from there, 172.16.225.1 should route it the final destination

If you already have a route built for 192.168.1.0/24 then you need to check your firewall settings

  • I have tried this, sorry I will edit my question to include this fact. It still didn't work. – Greg Brown Feb 19 '14 at 4:51
  • show me your routing table and a traceroute – CIA Feb 19 '14 at 5:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.