5

I've edited my ~/.Xresources and issued xrdb -merge ~/.Xresources and it worked perfectly. However when I restart X, the settings are changed to default. I've also added xrdb -merge ~/.Xresources in ~/.xinitrc but that did not worked. Please give a solution. I'm using Arch Linus with awesome wm.

1 Answer 1

7

If you aren't using a display manager to login, you need to add the following to your ~/.xinitrc file.

[[ -f ~/.Xresources ]] && xrdb -merge ~/.Xresources

Most display managers will load ~/.Xresources automatically.

3
  • i've added this line but it didn't worked! i've added exec awesome to xinitrc and it works so i can say xinitrc it being loaded
    – hhyttt
    Feb 19, 2014 at 4:40
  • thanks for your solution. i just added the line before executing awesome and it worked
    – hhyttt
    Feb 19, 2014 at 4:49
  • Awesome, I'm glad you got it working! :)
    – meskarune
    Mar 28, 2014 at 0:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .