5

I finally upgraded my work PC to Window's 8.1 Pro on Monday (from 8 Pro), but since then I have been having problems with websites not loading correctly. This issue is occurring in both Firefox 27.0.1 and IE11.

The website I'm trying to view does usually partially load but will not completely load. The spinner in the tab shows there is activity and clicking links does not work. In Firefox I see at the bottom the page Transferring data for www.wherever.com (IE doesn't show this though).

I use Firebug so have investigated the issue in Firefox with that, and it seems one of two things is happening -

  1. Not all scripts/styles/images/etc are loading and never do.
  2. All of scripts/styles/image/etc are loading but the HTML Response for the page I'm trying to view is truncated, with only a portion of the page making it to the browser.

I initially tried the obvious things -

  • Firefox -> History -> Clear Recent History...
    • Browsing and Download History
    • Form & Search History
    • Cookies
    • Cache
    • Active Logins
  • Internet Explorer -> Tools -> Internet options -> (General) -> Delete...
    • Temporary Internet files and website files
    • Cookies and website data
    • History
  • Disable all anti-virus

This didn't work so I tried reinstalling Firefox (and uninstalling IE11 entirely), but that also didn't work.

This is in a corporate environment where PFSense is used to manage the leased line connection that is being used, so there is no router in play that could be causing a problem. Besides, every other PC is connecting to these websites just fine (this is the only Windows 8/8.1 machine in the business).

I'm also fairly certain that it cannot be the network card as I have been successfully connected to several Terminal Servers since the upgrade without issue.

I'm now at a for what could be causing this, so I'd be grateful for any suggestions. Thanks.

  • Did you try starting Windows in safe mode with networking? If booting a Linux distro is an option, that could confirm whether it's a software issue. – and31415 Feb 19 '14 at 12:32
  • Will give it a try shortly... – David Gard Feb 19 '14 at 13:07
  • I guess you need to ask your IT team. Likely the scripts are blocked due to the URL or similar and your PC is missing that config files/settings – Dave May 3 '16 at 5:32
0

I've had this same problem (in Chrome and IE) since upgrading from WIN 8 to 8.1 and have been looking for solutions on Google. In the comments of an article on this same problem, someone contacted Microsoft support on this and received the following answer (I have just tried it and the problem seems to be solved):

This is Toni from Microsoft Customer Service.

As discussed over the phone, your issue opening websites via Microsoft Internet Explorer 11

  1. Please press the Windows key and the letter W. This will open the Settings Search.

  2. On the Settings Search field, please type Control Panel and open the Control Panel interface on the left panel.

  3. On the Control Panel, please choose the Network and Sharing Center option. If you do not see the Network and Sharing Center on the list, you may need to click on Network and Internet first.

  4. Please click on the Change Adapter Settings option on the left panel of the Network and Sharing Center window. This will open the Network Connections window.

  5. Please right click on your active network connection and choose Properties.

  6. On the Networking Tab, please highlight the option for Internet Protocol Version 4 on the list and click on the Properties button.

  7. On the General tab of the Internet Protocol Version 4 (TCP/IPv4) Properties window, choose the option for Use the following DNS server addresses and set the Preferred DNS server as 8.8.8.8 and the Alternate DNS server as 8.8.4.4

  8. Click on OK and Close.

  9. After setting up the global DNS settings, please check if you can now open websites in Internet Explorer.

I don't know why this works, but it seems to have fixed the problem for me and for many other people in those comments. You can view the article here: http://news.softpedia.com/news/Browsers-Not-Working-Properly-in-Windows-8-1-393582.shtml

Hope this helps others, since I had trouble finding a solution to this annoying problem.

  • 1
    Those 8.8.* IP addresses are Google's DNS servers. Changing your DNS server says that there is a problem with DNS somewhere. Perhaps the Web Page is loading a script or image from somewhere it can't get to. You could try using Fiddler to trace the HTTP calls being made and find out what/where it's choking, before you change the DNS Servers. Fiddler download is at telerik.com/download/fiddler – simon at rcl Sep 14 '14 at 11:21
-1

I had similar issues several times. After extensive research, I followed the suggestion to kill Google Drive. This worked each time (about three instances in a couple of months) and I finally just uninstalled Google Drive. I have had no problems since. I cannot find the original page to provide a link, and don't remember which specific resource Google Drive was hogging. But using Ctrl-Alt-Del, then task manager, followed by killing Google Drive is worth a try. You can always reboot and it will be back running again.

  • What does Google Drive have to do with this issue? – lzam Jun 12 '15 at 2:40
  • I thought I pretty clearly explained that I could not remember which resources it monopolized and could not find my source. Nevertheless, it solved my problem when the logical and straightforward network solutions would not. I hope this helps someone and saves them time. – mightypile Jun 12 '15 at 2:45

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.