I've got a NAS (Dlink DNS-323) that I mount from my linux box. It used to work fine, and then I upgraded my distro (apt-get upgrade). I'm running Linux Mint Debian Edition. Current kernel is:

oliver@astro ~ $ uname -a
Linux astro 3.11-2-amd64 #1 SMP Debian 3.11.8-1 (2013-11-13) x86_64 GNU/Linux

I used to mount it as a cifs share using autofs, but after the upgrade it became problematic. Specifically, I could mount the share, but if I read and/or wrote to it quickly it would hang and return a variety of errors. For example, opening a folder with a bunch of pictures in gThumb and then clicking the "next" button quickly is usually enough to cause it to hang. Once hung, no programs (including ls, lsof, fuser, graphical file system tools, etc.) can access the share - they all hang. However, reading and/or writing to the share "slowly" is fine.

I've tried a very wide variety of fixes including:

  • Lots of different mount options. Too many to remember them all, but some highlights include nounix, sec=ntlm, sec=ntlmv2, etc.
  • Mounting as an nfs share instead of a cifs share
  • Mounting via /etc/fstab instead of autofs. Tried this for both cifs and nfs

All have the same behavior. The problem is not the NAS itself as it continues to work fine from other computers in the house. The problem is also not the network card in this machine as I can browse the web, watch videos, etc. from it just fine. This seems to be specific to my Mint machine. Here is the line in my current /etc/fstab I'm using to mount the share via cifs:

//  /media/dlink    cifs    guest,rw,uid=oliver,gid=oliver,nounix,sec=ntlm  0   0

And here's the corresponding line from /etc/mtab:

// /media/dlink cifs rw,relatime,vers=1.0,sec=ntlm,cache=strict,uid=1000,forceuid,gid=1000,forcegid,addr=,file_mode=0755,dir_mode=0755,nounix,serverino,rsize=61440,wsize=65536,actimeo=1 0 0

The most common error I see in /var/log/syslog is:

Feb 19 17:01:47 localhost kernel: [  276.258055] CIFS VFS: Server has not responded in 120 seconds. Reconnecting...

That is by far the most common, and generally that's all I see. At some points I've seen other error messages though I'm afraid I can't reproduce them at this time.

One other clue. It seems that after I get errors with the drive I usually see the following show up in /var/log/syslog:

Feb 19 17:04:57 localhost minissdpd[4451]: 12 new devices added
Feb 19 17:05:01 localhost minissdpd[4451]: 1 new devices added

I know minissdpd is a UPnP thing and shoudn't have anything to do with this. It may be a red herring, but I see it so often after I have issues and I don't usually see it otherwise, so I thought I'd mention it.

Any ideas??

1 Answer 1


After a lot of debugging and looking at packet dumps I traced this to a network card driver issue. The network card buffer was overflowing so the TCP stack kept thinking that packets had gone missing. Switching network cards solved the problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .