In Windows 8.1, for some reason you have to configure your proxy settings through the Modern UI instead of the control panel, which is a lot more powerful. In the proxy settings menu, there is a toggle switch which allows you to use / stop using a proxy server. However, when I uncheck it, minutes later it re-checks by itself. This means that I cannot access the windows store, or use Modern UI apps online

How can I stop this box from autochecking?

This problem now is preventing me from using FTP meaning I cannot update my website at all. According to AVG, there is no malware on my machine.

  • Verify this does apply to you. – Ramhound Feb 20 '14 at 13:23
  • 1
    Have you scanned for Malware yet? Is a company computer? – Ƭᴇcʜιᴇ007 Feb 20 '14 at 13:53
  • 1
    I noted in one of your other questions to asked about distributing your own Metro app. If you're using Visual Studio and unit testing, it may be what's doing it. See Why do my proxy settings keep changing? – Ƭᴇcʜιᴇ007 Feb 20 '14 at 14:03
  • This must be some application that is doing that. You will need to find out which, maybe using autoruns. – harrymc Feb 24 '14 at 8:41
  • How can I find out the application doing this? Windows store apps do not work anymore! @harrymc – Ben Johnson mk2 Feb 26 '14 at 20:19

Do you have Hotspot Shield installed? Googling port 8555 seems to indicate that it uses that and results in a similar setup for the proxy servers. If you have Hotspot Shield installed, try removing it and see how that works.


There are way too many variables to try to figure out here why this is happening. Instead, try setting the registry values that manage the proxy. To that end, here's part of a VBscript I wrote a long time ago to help set the proxy.

Option Explicit 
const HKLM = &H80000002
const HKCU =  &H80000001
Dim strKeyPath, strProxykey, strProxyEnablekey, strProxyBypasskey, strSettignsKeyPath,  
Dim strProxyValue, strProxyEnableValue, strProxyBypassValue, strComputer, oReg
strKeyPath = "SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings"
strProxykey = "ProxyServer"
strProxyEnablekey = "ProxyEnable"
strProxyBypasskey = "ProxyOverride"
strSettignsKeyPath = "SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings"
strProxyValue = "ftp=proxy.you.co:80;http=proxy.you.co:80;https=proxy.you.co:443"
strProxyEnableValue = 1
strProxyBypassValue = "domains_that_will_bypass_the_proxy;seperated_by_semicolon;test."
strComputer = "."

'set WMI reg access
Set oReg=GetObject("winmgmts:{impersonationLevel=impersonate}!\\" & strComputer & "\root\default:StdRegProv")

'set proxy enable
oReg.SetDWORDValue HKCU,strKeyPath,strProxyEnablekey,strProxyEnableValue
'set proxy server
oReg.SetStringValue HKCU,strKeyPath,strProxykey,strProxyValue

If you change the appropriate values, you can run this after it's changed to set it back. Also, you can see that the magic of proxy settings happens in "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings"

On a separate note, you can also modify the ACLs for a registry key so that whatever is changing it cannot. But I'd strongly recommend against this because the most likely scenario is that you'd have to remove SYSTEM and you make end up locking yourself out or causing other problems.

Hope this helps.

Not the answer you're looking for? Browse other questions tagged or ask your own question.