0

I'm using a USB keyboard which works fine on Windows, but on Linux (Ubuntu and Fedora) this happens.

When I press ctrl C to copy some text, the keyboard stops working and I can't type anything anymore. Sometimes it also prints something like this: ctrl^C ctrl^C ctrl^C ctrl^C ctrl^C ctrl^C ctrl^C ctrl^C ctrl^C ctrl^C ctrl^C

What can I do? I couldn't find any information about this on the internet.

I can't see anything on syslog and dmesg either.

5
  • Ive had this problem, Its actually a problem with the keyboard. Windows doesnt show the errors but it does happen in windows too. I noticed it when connected to a micro controller and it was sending the keypresses to the micro controller repeatedly giving weird behaviour – exussum Feb 20 '14 at 14:21
  • @user1281385 But how come it works fine? How can it be sending keypresses and Windows not reacting to them? Doesn't sound correct. Besides it only happens with ctrl c (not with ctrl alone, and not with c alone) and only on Linux. – PhysicsEnthusiast123 Feb 20 '14 at 14:59
  • @user1281385 Now I tested it on my laptop with Fedora 17 and works fine too. So it's definitely not a problem with the keyboard. – PhysicsEnthusiast123 Feb 20 '14 at 15:03
  • Get a new keyboard. – Rudolph Feb 20 '14 at 15:21
  • Kindly provide information on how the problem was resolved. It was a mere suggestion to isolate the problem to the specific keyboard in linux. I have seen many hardware problems in both windows and linux that proofs isolation towards the OS and hardware is a necessary move. superuser.com/questions/719235/…. It also appears you are experiencing other problems with the keyboard. – Rudolph Feb 21 '14 at 5:25
0

If this happens for both ctrls (left and right) then I would suggest that you check your Keyboard layout and your IBus settings.

0

Apparently USB keyboard can have conflict with USB mouse depending on the ports you use in Linux. I tried plugging it in many different USB ports until it worked. This command helped:

$ sudo lsusb -l
0

If you have a terminal open then the Ctrl+C functionality is different on Linux, it instead sends a SIGINT to the foreground process group. To copy in a Linux terminal you have to press Ctrl+Shift+C.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.