30

Chrome gives this error, yet I can ping the server!

The server at www.odesk.com can't be found, because the DNS lookup failed. DNS is the network service that translates a website's name to its Internet address. This error is most often caused by having no connection to the Internet or a misconfigured network. It can also be caused by an unresponsive DNS server or a firewall preventing Google Chrome from accessing the network. Check your Internet connection. Check any cables and reboot any routers, modems, or other network devices you may be using. Check your DNS settings. Contact your network administrator if you're not sure what this means. Try disabling network prediction. Go to the Chrome menu > Settings > Show advanced settings... and deselect "Predict network actions to improve page load performance." If this does not resolve the issue, we recommend selecting this option again for improved performance. Allow Chrome to access the network in your firewall or antivirus settings. If it is already listed as a program allowed to access the network, try removing it from the list and adding it again. If you use a proxy server... Check your proxy settings or contact your network administrator to make sure the proxy server is working. If you don't believe you should be using a proxy server: Go to the Chrome menu > Settings > Show advanced settings... > Change proxy settings... > LAN Settings and deselect "Use a proxy server for your LAN". Error code: ERR_NAME_NOT_RESOLVED

$ ping odesk.com

Pinging odesk.com [64.41.140.207] with 32 bytes of data:
Reply from 64.41.140.207: bytes=32 time=103ms TTL=47
Reply from 64.41.140.207: bytes=32 time=103ms TTL=47
Reply from 64.41.140.207: bytes=32 time=103ms TTL=47
Reply from 64.41.140.207: bytes=32 time=103ms TTL=47

Ping statistics for 64.41.140.207:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 103ms, Maximum = 103ms, Average = 103ms

$ ping www.odesk.com

Pinging e5489.g.akamaiedge.net [23.199.64.63] with 32 bytes of data:
Reply from 23.199.64.63: bytes=32 time=665ms TTL=52
Reply from 23.199.64.63: bytes=32 time=389ms TTL=52
Reply from 23.199.64.63: bytes=32 time=541ms TTL=52
Reply from 23.199.64.63: bytes=32 time=578ms TTL=52

Ping statistics for 23.199.64.63:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 389ms, Maximum = 665ms, Average = 543ms

I restarted Chrome, and I also disabled my network adapter and re-enabled it. I also ran ipconfig /flushdns. 'Predict network actions to improve page load performance' is already off.

4
  • Did you solve it, and if yes, how? I'm seeing the same problem, I suspect the DNS is not propagating properly.
    – Mahn
    Dec 30 '14 at 16:14
  • 3
    I've seen the same problem, and this is not an issue with the data in the DNS system. I tried two different servers with dig, host and ping, all of which gave correct information, yet Chromium on my Ubuntu box couldn't find the record. (Chrome on Windows and on an Android tablet worked fine at the same time.) Clearing Chrome's DNS cache did not help. The problem went away after a couple of hours.
    – cjs
    Aug 13 '15 at 4:03
  • I cleared my cookies (domain and sub-domain) and it worked (don't ask why) ! Sep 20 '16 at 12:47
  • I had similar issue, was only affecting chrome browser. I had to turn off "Use Secure DNS" in chrome://settings/security. Once I did that and refreshed I could turn it back on and the issue was gone
    – BlackICE
    Nov 12 '20 at 14:31
18

You can try to disable Google Chrome's DNS Prefetching: Settings > Show Advanced Settings > Privacy and disable the option Predict network actions to improve page load performance.

Alternatively, flush Chrome's DNS cache.

enter image description here

More details here.

6
  • 4
    I already had Predict Network Actions turned off, but I think chrome://net-internals/#dns is the ticket!
    – Chloe
    Apr 4 '14 at 19:18
  • 2
    I have the same problem, but this solution for me it is not working. (I am using a new tld category) do u have any tips?
    – Nk SP
    Dec 26 '14 at 21:54
  • me neither. Everytime this problem occurs, Reinstalling the chrome is inevitable solution for me. Mar 12 '15 at 8:42
  • 1
    Does not solve: "DNS_PROBE_FINISHED_NXDOMAIN"
    – YumYumYum
    Jul 7 '15 at 4:20
  • I tried the clear host cache and it worked, but tried to view again and had the same issue again. Any ideas?
    – TomC
    Jan 16 '19 at 10:48
20

I had the same issue. I'm working on a windows system (8.1) and had the problem with almost every page in google chrome, IE 11 and Firefox.

this is what worked for me

Win + R, type in "cmd", right click and select "run as administrator"

Then type the following commands (enter in this order):

ipconfig /flushdns
ipconfig /renew
ipconfig /registerdns

I did not have to restart my pc, but everything worked again all pages in the internet were available again.

3
  • In case anyone has a Mac: see this page for how to flush the DNS cache.
    – jvriesem
    Jul 30 '15 at 17:26
  • 1
    Strange thing is that a site was working on IE11, but not on Chrome 50, yet "ipconfig /registerdns" fixed the issue.
    – Jussi Palo
    Apr 26 '16 at 8:19
  • just a quick note, to perform this commands you need to run as administrator.
    – dippas
    May 20 '17 at 14:08
0

It could be a DNS issue that can be solved by changing the DNS address to either Open DNS or Google DNS. May also require power cycling your PC and router. Check details here - www.pcappspot.com/fix-err-name-not-resolved/ One of my friend had this issue and later found out that his ISP put him through a safe browsing filter and everything worked fine after he asked the ISP to remove the filter from his IP.

2
  • 1
    I don't find your answer consistent with the fact that the OP can ping the server. IMO it's got to be browser-specific. Jun 16 '15 at 13:55
  • The thing is you can't be sure about the solutions for these kind of problem. They can be caused by browser, DNS, ISP and many other things. You just gotta keep trying one after another until it fixes.
    – Mahmud
    Jun 16 '15 at 22:37
-1

i have had this issue REGULARLY and the ONLY fix for me is to set my Network Adaptor DNS to 8.8.4.4 and 8.8.8.8 (google) all web pages are now showing up!

Not the answer you're looking for? Browse other questions tagged or ask your own question.