0

We have a Server 2008 (x86) computer which acts as a server, also as a router to share Internet into multiple network segments with RRAS.

Everything works fine except DHCP on a wireless adapter with ad-hoc type of network. Same DHCP server works fine on the wired ethernet segment.

I checked and re-checked, and re-created the scope for the wireless ad-hoc net multiple times, with no result. It just doesn't respond to client requests whatsoever (I sniffed with Wireshark). If I manually specify IP parameters on the client, everything works fine: the Internet can be accessed, routing between net segments works fine etc. It's just DHCP that doesn't work.

The ultimate irony is that we had a similar configuration also with 2008 server x86 and the same wireless adapter, that worked perfectly fine. Then we changed the server hardware and reinstalled Server 2008.

Maybe there are some relevant fixes/updates that we had on the old server, but are missing now? Currently we have only the mandatory updates applied to date, no optional ones.

Any ideas?

1
  • why are you using ad-hoc? The point of ad-hoc is that you DON'T have a traditional network infrastructure in place such as the server you're using for DHCP. Why not just have it set up as standard wireless access points?
    – MaQleod
    Feb 20, 2014 at 22:21

1 Answer 1

0

Answering my own question, just to close the topic.

Turned out that the wireless interface was not listed among the bindings of the dhcp server. I had to connect a wireless client, then restart the dhcp server, then add the binding. After these steps everything works fine as it worked on the old server.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .