I watched Wi-Fi Protected Setup (WPS) in Windows 7 on Channel 9 and would love to test it out. But my laptop is already set up. In the video one of the guys go into the command prompt and runs some command starting with netsh, but then zooms out so you don't get to see the rest of what he writes.

Does anyone know what he writes there to make his laptop completely forget about the Wi-Fi settings he just set up?

4 Answers 4


If you open the Network and Sharing Center, then click on "Manage wireless networks" you can remove all saved wireless network profiles.

  • That seemed to work :) But didn't get the new Wi-Fi connect dialog though... maybe it is something that has been done after the RC and will be in the final release...
    – Svish
    Commented Jul 18, 2009 at 12:14
  • this doesn't answer the question about the command used, and in some cases (ie. you are not admin) this answer also doesn't work. Commented Aug 9, 2018 at 17:12

I think it's probably the Delete command:

netsh wlan delete profile name="ProfileName"

Where ProfileName is the name of the profile you set while creating the connection—which you can find using the List command:

netsh wlan show profiles
  • I bet there is probably an "all" trigger or something to remove every profile.
    – Weaver
    Commented Jul 17, 2009 at 15:44
  • when I start netsh, and then type delete and press enter, I get "delete helper - Removes a helper DLL." Doesn't seem right...
    – Svish
    Commented Jul 17, 2009 at 15:52
  • you have to be in the wlan section I believe. when you start netsh, you then type wlan and it takes you to the wlan interface section which has different commands.
    – Weaver
    Commented Jul 17, 2009 at 17:52
  • I did, but the delete command reported the same usage.
    – Svish
    Commented Jul 18, 2009 at 12:13
  • Try this.....netsh->wlan->delete profile name=* i=*
    – Weaver
    Commented Jul 21, 2009 at 14:54

Open CMD as Admin and run the following command:

netsh wlan delete profile name=*

Works perfectly.


I had an SSID I couldn't make go away. I tried refreshing the available connections list, turning the radio off and on, resetting the cable modem, the netsh commands mentioned in another answer, searching the Registry for the SSID and deleting all of the associated keys - none of that worked. I was finally able to make it go away by disabling the wireless profile, then using the network troubleshooter to re-enable it (because "Disable" never changed to "Enable"). When the connection list came back up, the offending SSID was finally gone.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .