I have WD My Book Essential 3TB external drive for more than 2 years now. It worked fine until about a month ago when it stopped being recognized. After extensive googling, I ran chkdsk /r on it and it was fine. The next time I used it, about 2 weeks after, again it was not recognized. I was not able to use it until yesterday. After a very long time, my laptop was able to recognize it. I tried to copy some of my files to another hard drive but the transfer speed dipped to about 700 kb/s. As I have at least 450 GB of important files (this excludes the other 900+ GB of files), this transfer rate will simply not do.

I turned my computer on now and this is the shot of the Disk Management:

enter image description here

Trying to access Drive F though was almost impossible. I went to command prompt to access the files but I was only able to access the root directory. I cannot go to the subdirectories. Refreshing the Disk Management, my drive is already gone - Unknown, Not Initialized.

The funny thing is, unlike all of the previous times, I can see the drive in explorer: enter image description here (although I can only go as far as the root directory). But the drive is Unknown in Management.

I tried to run chkdsk from the administrator command prompt but it kept saying "Cannot open volume for direct access."

I already tried pulling the 3.5" SATA drive from the enclosure and connecting it to a desktop PC, swapping the hard drive with another WD Essential external drive (different model though, 1TB) - which all didn't work probably because of the hardware encryption.

I really need to recover those files before I get another enclosure/dock to format the hell out of this hard drive. I'm running out of hairs to pull. Somebody please help.

  • Sounds like the drive has failed. You really should have backed up the files when you had to run the chdisk tool the first time – Ramhound Feb 21 '14 at 12:25
  • @Ramhound Now, I consistently am able to see the hard drive. But only after a long time. Read times are maybe 50x slower than usual. I will try to extract data or maybe try cloning with Acronis. – ome Feb 24 '14 at 13:31

You do not mention many symptoms, so it's hard to say what the issue is.

First of all "this transfer rate will simply not do" is irrelevant. When a drive is dying any moment that you have access to it should be used to copy your data off. Consider yourself lucky that it comes alive one more time instead of complaining about the transfer speed. Leave it on, don't reboot, and keep copying your data off it, even if it takes weeks. That is the first thing you should do. Even having run chkdsk was a bad idea.

If your drive is not making clicking noises I suspect the drive surface. The procedure I recommend in these cases is:

1) Do not shut down/reboot any more than necessary. If the bad spots are in critical sectors at the beginning of the disk the system may not boot up again. Write processes on shut down/reboot may also worsen the situation.

2) Avoid writing to the disk. Pulling it out of your computer and putting it in another computer as a non-primary disk is a good way to prevent software (the OS) from automatically writing to it. You already tried that.

3) Optionally, try to make an image of the entire disk or in one way or another pull all the important data from the disk. There's lots of variations on how you can do this, but whatever method you choose, read only!. You're doing that now.

4) Run software that will check for and fix bad sectors.

In ascending order of thoroughness (which generally also indicates the time they will take to run) I recommend:

Run Seatools for DOS (not the Windows version; download the ISO), and choose the 'LONG Test'. This program is free.

Run HDD Regenerator. This program is not free ($99 US).

Run SpinRite (running the executable under Windows will extract an ISO that you can burn). Choose level 4 for thorough testing. This program is not free ($89 US) and is the only one that I know that can often recover data from damaged sectors; this may take a long time though. It comes with a money-back guarantee.

All three programs scan the hard disk at the physical level, and should be run from a bootable CD. They don't care what OS file system is being used.

5) Finally run software that does logical checks on the disk structure, like chkdsk. This could very well not find any errors after step 4.

Added 21 feb 2014:

1) People often have the tendency to do step 5 before 4: chkdsk is at hand so why not use it quickly. This is not optimal. If the disk sectors are bad and this leads to corrupted file allocation structures, tools like chkdsk will do their best to fix the logical file structure. What they fix here is irreversible. They will generally not be able to recover everything. If you first do step 4 and it's just a matter of damaged physical sectors, those kind of programs may well be able to revive or reallocate the bad sectors and keep their data. If that happens the OS will no longer have problems with the file allocation structures and all the associated logical data structures will be fine (that's why I wrote "This could very well not find any errors").

2) You may not have a spare disk at hand or may not be able to read from the damaged disk to do step 3. That's OK, step 3 is just a generic precaution: "Before you start doing anything irreversible (steps 4 and 5) try to get as much data off as possible".

| improve this answer | |
  • 1
    As Jan points out ALL of these tools are for one simply thing to get the drive to a point where the data can be copied ( except for Seatool since that would only confirm the drive has failed ). The only change to the advice would be to run Level 1, then Level 2, then Level 3 scans within Spinrite before running level 4. – Ramhound Feb 21 '14 at 12:30
  • BTW If anyone reading this is familiar with copy software that can perform step 3 (like user302078 in a separate answer) without changing one bit on the original disk feel free to edit my answer and recommend those tools under step 3). – Jan Doggen Feb 22 '14 at 11:09
  • @JanDoggen hey thanks a lot. I tried HDD Regenerator, the limited version. It said it will try to fix the first bad sector it encounters. It encountered one, but failed to fix it, ran some more before I paused it. I guess it's not that type of problem. – ome Feb 23 '14 at 13:40

I have two WD MyBooks. Haven't had a prob so far. A couple times I had to save data from hdd though. I just popped in a PCLinuxOS XFCE live disc & transferred. But, both MS & Linux does not like to transfer large folders. Had to grab at most 4 ~300mb videos at a time otherwise they got corrupt. Even though both OSes showed transferring x amount & took the time to do so. If you can transfer your files safely using live, then afterwards use live gpart to reconfigure the drive into four NTFS partitions. Live can be used to see the health before & after you do anything. Good luck.

| improve this answer | |

I couldn't run CHKDSK or look at folders, etc. This was after I got passed the whole Not initialized bit.

Here's how I got the files off of the drive:

I'd have a Command Prompt window open ready with CHKDSK and power up the docking station. As soon as the drive popped up I'd run CHKDSK then right away (while CHKDSK was running) open the drive and copy my files over and for some reason it works.

After it finished copying I'd have to do the same thing for the next folder.

Disclaimer: I don't know which part of my drive is failing but mechanically it sounds in perfect working order. Also, there is a good chance this won't work for you or others and could be a very specific problem with my drive.

edit: Mine is a Seagate Barracuda 7200.12 SATA drive.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.