4

My pgAdmin3 install has run into a problem (windowing glitch that renders it unusable), and I want to try completely removing it from my system and installing it freshly to see if that resolves the issue. I've tried simply deleting the app and reinstalling that, which doesn't help, but when I do that it also remembers server connections from the previous install, so it must be leaving files somewhere. What do I have to clean up to completely remove pgAdmin3 so I can do a fresh install?

System info: Mac OS X 10.9.1 Mavericks, with pgAdmin3 v1.18.1 installed from the .dmg file downloaded from pgadmin.org

I have already tried

locate .pg*

which finds two files: .pgadmin_histoqueries and .pgpass both in my home directory - removing both didn't change anything. I've also removed pgadmin.log - again no effect.

I've also tried restoring pgAdmin3.app from Time Machine from before the windowing glitch started, but that also doesn't solve anything.

  • On my Linux system the only config file it seems to use is ~/.pgadmin. But on OS X, I'd check the Library too. There's no guarantee it's PgAdmin saving and restoring the window state; it could also be a window manager / Finder issue. – Craig Ringer Feb 22 '14 at 4:33
  • Thanks for the pointer, but I don't see a ~/.pgadmin on OS X - I'm guessing the different builds use different file structures. – Eldan Goldenberg Feb 22 '14 at 22:34
4

Check your ~/Library/Preferences-Folder. There are the following files you should also remove:

  • org.postgresql.pgadmin.plist.lockfile
  • org.postgresql.pgadmin.plist
  • pgadmin3 Preferences

Remove these also. Especially the last one which contains the server-list.

The org.postgresql.pgadmin.plist does seem to contain some information regarding the windowing system. So perhaps removing that one first might already do the trick.

  • Thank you! I didn't have the presence of mind to try just removing the .plist first and check if that was adequate on its own, but certainly removing the two has sorted this out. – Eldan Goldenberg Feb 22 '14 at 22:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.