0

I have a Hitachi Compact Flash Microdrive that my Canon EOS 20D uses to store pictures on. Up until recently, I've been able to put the microdrive in a PCMCIA reader ("PC Card Reader" as described in Wikipedia article), and put the reader into my Windows 8 Professional 64 Bit laptop and it would show up as a storage device (much like a USB flash drive or external hard drive).

Today, for the first time, it didn't work. The behavior I get is:

  1. "Device connected" sound plays
  2. "Safely Remove Hardware" system tray icon appears
  3. No new storage devices appear under "This PC" in Windows Explorer

The last bit is what is unusual or "broken."

If I go to Disk Management, I see my laptop hard drive and DVD drive, but no additional drives.

If I click on the "Safely Remove Hardware" system tray icon, and then choose "Open Devices and Printers", I do see "HITACHI Microdrive" at the bottom of the list, in the group "Unspecified". It is the only item in the "Unspecified" group.

I've tried:

  1. Right clicking on "HITACHI microdrive" in "Devices and Printers", and choosing "Troubleshoot", but Windows finds no problems.
  2. Right clicking on "HITACHI microdrive" in the "Devices and Printers" screen, choosing "Remove device", physically removing the PCMCIA reader (and microdrive), and then adding it back. Same behavior as before.
  3. In Device Manager, under "IDE ATA/ATAPI Controllers," right clicking on "PCMCIA IDE/ATAPI Controller" and choosing "Uninstall". I then eject the reader, reinsert, and get the same behavior.
  4. Putting the same PCMCIA card reader, with the same microdrive, in another computer. Actually, another Latitude D830. It works perfectly and I can access the drive from there.

Nothing I've tried has restored the microdrive to the list of storage devices available in Windows Explorer on my D830 (although, as noted in step 4, it works in a different D830).

We haven't installed any new software, although Windows does automatically perform updates. It's been months since we tried to copy data off this drive, so many updates have potentially been installed.

Since it works on a different laptop, it is apparently related to my laptop, and not the microdrive and/or PCMCIA reader.

Suggestions on what to try next?

0

Have you tried rebooting with the Microdrive connected?

There's also a possibility that the Microdrive has failed. You'll need to use software that reports SMART data, such as a system information utility. Something like DiskCheckup from Passmark Software, Speccy by Piriform, or maybe AIDA64.

  • I did try rebooting with the microdrive connected. The microdrive still works in the camera, but I suppose that doesn't 100% rule out a problem with the drive. I'll update my question with that information, and I'll also look up those software tools you mentioned to check the SMART data. – Josh Feb 23 '14 at 20:25
  • The microdrive and reader are working fine on a different laptop. I updated the question to note this. – Josh Feb 26 '14 at 12:40
0

Since you say the microdrive works in the camera, it is more likely a problem with your computer. Do you have any posibility of trying to connecting the device to another computer to check that ?

Also, maybe you could try deactivating the microdrive from the peripherals manager, then reactivating it back in, it helped me once in a similar situation (do you hear the drive spin, by the way ?).

I'm not sure for an English OS, but the correct menu option might say something like "deactivate" (above "uninstall" and "look for modifications on the hardware").

PS : I did not check but I'm not sure microdrives have SMART.

EDIT/PS2 : oops I mixed up uninstall (which you tried and failed) and deactivate

PS3 : Hold on... did you remove the Microdrive itself or the PCMCIA adapter ? (either physically or from peripherals manager)

PS4 : sorry it's getting late, I didn't even think of asking if you could borrow a CF reader (although I do have a doubt about the form factor ?) to distinguish between problem of microdrive and PCMCIA adapter

  • The microdrive and reader are working fine on a different laptop. I updated the question to note this. – Josh Feb 26 '14 at 12:41

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.