1

There is one machine on my network that can not access one of our websites!

Chrome just idles for a while then says "Oops can't connect", similar behavior is observed in other browsers too. Nslookup finds the domain's IP and ping (by IP) works with a high TTL. Ping by domain just times out.

The site is on a shared host with several of our other websites hosted there. The affected machine can visit our other websites occasionally - sometimes they load very slowly if at all. One particular website wont load at all.

All other machines on the network can access and interact with the site, as too can machines outside of the building. The problem is entirely constrained to one machine.

All machines in the office are running Win XP Pro.

These are the things I've tried, either in conjunction with one another, or individually:

  • Assigning a fixed IP
  • Renewing the IP lease
  • Flushing the local DNS cache (ipconfig /flushdns)
  • Connecting directly to the main router (bypassing the switch)
  • Connecting to a different router
  • Cold reboot
  • Ping by IP (works slowly)
  • Ping by domain (time out)
  • Tracert - very slow, gets there in the end
  • nslookup finds the domain's IP
  • Changing the network cables
  • Emptying Chrome's cache
  • Trying a different browser (Maxthon)
  • Running CCleaner
  • Running a spyware & AV check
  • Disabling the machine's firewall and AV
  • Checking windows firewall is still disabled
  • Adding an entry to the hosts file
  • Using Google's DNS servers
  • Rebooting all the network hardware
  • Changing the MAC address on the router
  • Accessing site directly by IP to avoid DNS lookups
  • Checked cPanel isn't blocking our IP

I'm stumped!

This just makes no sense to me and I've exhausted all the things i can think of to correct this issue, apart from a clean re-install which isn't necessarily the most viable option.

Anything else i can try?

  • What web server and version are you sing? What port are you using? Are you using host headers? Are you using ACLs? – CIA Feb 24 '14 at 1:32
  • It's a shared host, and they are using LiteSpeed V6.6. Standard port 80 is used (no SSL). There are no ACL's that i'm aware of or have access to. I've checked cPanel and there is no available configuration for the firewall, besides the site is accessible from other machines on the same network – Rucia Feb 24 '14 at 1:40
  • New network card? – Canadian Luke Feb 24 '14 at 2:09
  • Its still the existing NIC - was working fine between 9am and 10am then at 10:05 it wasn't working - very odd. – Rucia Feb 24 '14 at 2:15
  • Try a new one. I'll bet that's it – Canadian Luke Feb 24 '14 at 2:44
0

It looks like you did most troubleshooting already. One of the last things to try is a new Network Interface Card (NIC).

Routers that are on their way out have some of the same symptoms as what you're describing, but you already switched that out. Try a new network card, just for testing purposes. You can try a USB NIC first; if it doesn't work, you at least have a spare NIC to use elsewhere. If it works, you can invest in a proper internal NIC.

| improve this answer | |
  • OK, finally tested this. Bought a new NIC and it didn't resolve the challenge. To compound matters further another machine in the office now has the same challenge (still leaving 8 machines working fine). Any other ideas? – Rucia Apr 15 '14 at 5:40
  • Try resetting the TCP/IP stack: netsh winsock reset from the Administrative Command Prompt, then reboot. Next thing is switch a working computer into the non-working location, and see if the effects are still there – Canadian Luke Apr 15 '14 at 5:43
  • Just tired that on both machines - no go. Just tried a laptop in the location with the lan cable and that works. so its not the switch, router or cabling. – Rucia Apr 15 '14 at 6:00
  • Well, it's something to do with those computers then, and like I said, you did most of the troubleshooting already. Sorry I can't help more – Canadian Luke Apr 15 '14 at 11:46
  • OK it's fixed now! The solution was to run netsh int ip reset log.txt and then followed straight away by ipconfig /flushdns plus a reboot. Thanks for all your help! – Rucia Apr 16 '14 at 3:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.