5

I have a Debian PC(Server) and I would like to remote this machine from one client(Window, Ubuntu,..) and i can hear the sound from Server.

I try some tools(Radmin, RealVNC,..)(I can not use Teamviewer cause of pricing) but I can not transfer sound from server to client.

So, my question is what tool can solve this issue?

Any suggestion would be appreciated!

2
  • 2
    Teamviewer is free for non-commercial use.
    – martineau
    Feb 24 '14 at 2:14
  • @martineau We are in commercial use :-) Feb 24 '14 at 2:17
2

My Remminia version is 1.4.2, on Ubuntu 20.04 LTS.

It works for me to change Advanced => Sound from Off to Local - high quality.

1
  • Even with 1.3 this brings the sound for Me. I tried all Local options. Simple "Local", and "Local - low quality" sounds poor, and clicky. "Local - high quality" is enjoyable, and between them is also acceptable.
    – CLS
    Apr 1 at 12:15
1

Update: The following answer is not valid for Remmina versions greater than 1.1.0 as the sound options seems to be gone.

Remmina is a remote desktop client written in GTK+, aiming to be useful for system administrators and travellers, who need to work with lots of remote computers in front of either large monitors or tiny netbooks. Remmina supports multiple network protocols in an integrated and consistent user interface. Currently RDP, VNC, NX, XDMCP and SSH are supported.

One of my chief complaints with some of the other RDP clients available for managing desktops from Linux is the poor remote audio support. Although you can generally ‘get’ sound to work, you won’t like what it sounds like. Remmina handles remote sound beautifully, clearly giving you the option of leaving your audio in place or ‘bringing’ it to your desktop, see the options screen below:

enter image description here

3
  • 3
    In Remmina 1.1.2 seems that option is gone. No option related to Sound.
    – chomp
    Aug 31 '18 at 23:26
  • 2
    I think this answer should be edited to include @chomp's comment on the first line. I don't know if 1.1.2 is the first version where that option disappeared, but it's definitely no there in 1.4.7.
    – Enlico
    Aug 7 '20 at 7:49
  • 2
    The option is still there, but you have to make the changes before the connection is established.
    – borland502
    Feb 15 at 15:57
0

Just wanted to record experience here. Have used remmina 1.1.2 for years and had remote sound w/no configuration or special setup. suddenly stopped working from ubuntu clients (windows mstsc clients could still get sound fine). also whenever you'd adjust the sound via ubuntu, it would hang a bit. no updates to os/client.

completely closing remmina and restarting it seemed to fix it.

obviously pretty basic solution but easy to miss bc it tends to stick around in system tray. hopefully this helps somebody.

0

The answer, for any that come after, is that you have to go to the advanced options and enable sound before connecting to the computer. The advanced options are disabled after the connection is established

0

I was experiencing this problem with Remmina 1.4.21 on Fedora 35 and was able to resolve the problem doing the following:

  1. Disconnect from the current remote session
  2. Right-click your Connection Profile -> Edit -> Advanced
  3. Audio output mode -> Change to Local -> Save

Note: If you don't have a Connection Profile, there should be a button somewhere to create one. In my instance, it is in the upper left, New connection profile

Regarding the sound quality: I had to remote into a Win10 machine and I notice the sound is echoey, VERY distorted, and "metallic" sounding using Local audio. I just need a basic notification noise for a task I run occasionally.

You could set the audio output mode to Remote if you wish to use the speakers from the device you are remoting into, but you won't be able to hear them through your Local speakers or headphones. (This might be a good option if you're just trying to play music from a different room and the remote machine's speakers are very good.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.