SSD main drive died in a computer. Windows 7 Home Premium, 64-bit. Had a weekly Windows Image backup on one of its hard drives. Replaced the SSD with a newer, bigger SSD.

Booting from the Windows 7 DVD. Statup repair first refused to work because a critical drive was missing. Discovered the the hard drive with the recent backup was marked "foreign" in diskpart, imported and tried again. Now it refused to restore because the source disk was a dynamic disk. I moved the entire WindowsImageBackup folder to a different hard drive. (There's a sad, sad story about the misuse of the /mir flag on robocopy here.)

We're now at error 0x80042412, no disk can be used to restore. There are only two disks on the system now, the source backup hard drive and the new SSD. I've used diskpart to clean the SSD; that requires a restart, then it still doesn't work. I've also used it to create a partition table with the 100 MB partition and the remainder as a second partition. (see http://www.sevenforums.com/backup-restore/65205-re-image-system-disk-fails-error-0x80042412.html)

I can't find anything else to try. Is there a way to force Windows to load this image, or is my best bet at this point to do a fresh install on the SSD, load the VHD backup, reimage it using something else to ISO format, and then restore that image using Reflect or something like that?

  • I wound up reinstalling Windows, attaching the VHDs, and using Acronis to reimage them and restore them to the main SSD. This worked flawlessly, so there was no problem with the actual backups. Would be interested if someone knows how to make Windows itself restore in this situation. – schodge Mar 10 '14 at 9:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.