My router is a Netgear N150 Wireless Router, model WPN824N. Right now on my home network I’m able to connect wirelessly and access the Internet with two iPads, a phone, and a PS3. I’m also able to connect with a PC that is wired in directly.

However, my laptop cannot seem to get full Internet access anymore. It detects the wireless network, connects to it, and has decent signal strength. I can even ping www.google.com. However, if I try to actually load a web page (such as www.google.com), the connection times out. This happens in Internet Explorer, Firefox, and Chrome. If I plug the laptop into the router directly—and thus not using the wireless connection—it works fine.

I chalked this up to my laptop’s wireless card getting flaky or something, since it used to work. Since I rarely use it, I just ignored the problem and stopped using the laptop to connect wirelessly. However, I recently brought home my work laptop, which has no trouble connecting to the wireless network at work. When I connected to my home network, everything seemed to work for about 2 minutes. I loaded Google and brought up email. Some time while drafting the email, it stopped working. Just like my other laptop, I’m still connected to the wireless network, can ping google, and otherwise appear as if I should be working. However, web pages simply won't load, and the network status occasionally flickers between telling me I have Internet access and no Internet access.

Through all this, my iPads, phone, and PS3 continue to work fine for web browsing or video streaming via Netflix.

What kinds of steps can I take to diagnose and solve a problem where laptops seem unable to get full Internet access?

  • You could statically allocate an IP. I had an old Dell that behaved exactly this way on DHCP but worked fine with a static. it's not a solution but perhaps a workaround. Also look into where the laptop is failing to get out to the internet. Might help to add that to the question. – Joe Taylor Feb 24 '14 at 15:07
  • Can you elaborate on how I'd go about performing that 2nd suggestion? – Sterno Feb 24 '14 at 15:10
  • I was just playing around with my router settings and turning "Enable WMM (Wi-Fi multimedia) settings" on seemed to fix this. However, I turned this off over a year ago because it was causing slowdowns with my iPad browsing, and my laptop also worked for months after I'd disabled it. Does this make sense as the culprit? Having it on, I'm likely to be back to the old problem where the iPad speed is very slow. – Sterno Feb 24 '14 at 15:27
  • That might make sense if traffic is congested. Who knows what that router is doing though... Maybe it's time to pick up a different one? – Tanner Faulkner Feb 24 '14 at 15:33
  • I'm no networking expert but maybe tracert could help. Does it get out to the site you're trying to get to? Does it fail at the router. Does it even get to the router etc. Just gives you a bit more info – Joe Taylor Feb 24 '14 at 15:35

Well, I don't like my solution, but I'd better post it since it actually solved the problem I'm having.

I had Enable WMM (Wi-Fi multimedia) settings on the router turned off because having it on had been causing speed issues with my iPad. The laptop, at least for a while, had worked fine with that disabled. Turning it back on, however, made both laptops work again. So, if someone else has this same issue, you might try making sure that you have WMM enabled to see if it fixes your problem.

The steps to check this for my router were:

  1. In a browser, go to Log in with username/password for router.
  2. Go to the Advanced Wireless Settings
  3. Tick the Enable WMM (Wi-Fi multimedia) settings checkbox and hit Apply.

My router's help has this to say about WMM:

WMM (Wireless Multimedia) is a subset of the 802.11e standard. WMM allows wireless traffic to have a range of priorities, depending on the kind of data. Time-dependent information, like video or audio, will have a higher priority than normal traffic. For WMM to function correctly, wireless clients must also support WMM.

Why having that disabled would block the laptops entirely from web browsing is a mystery to me.

| improve this answer | |

Set your router WIFI channel to 1. Older laptops have troubles connecting to higher WIFI channels.

| improve this answer | |

Before checking wireless card:

  • Try installing wireless driver(s) for the card.
  • Also check the Proxy and DNS settings (make it to "Automatic" option).
  • And if the problem still, try to reinstall the OS (Operating System).
  • Otherwise diagnose physically the the wireless card.
| improve this answer | |
  • Could you elaborate on "Check the Proxy and DNS Settings"? Check for what? Make it automatic how? – Sterno Feb 24 '14 at 15:20
  • If you have windows, go to "Network and Sharing" (just google it) => "Manage Wireless Cards" => double click on your wireless card => "Properties" => search for "... IPv4", then make all options automatic => Apply => OK => OK. – user4388 Feb 24 '14 at 15:27
  • 1
    I really wouldn't look at reinstalling an OS as a 2nd troubleshooting step. You have 2 seperate laptops displaying the same issue. It's more likely to be a config setting on your router – Joe Taylor Feb 24 '14 at 15:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.