3

I want Windows to show the last user logged, so I only need to type my password, and I don't need to select my username. I thought it should be the default Windows behavior, but I've just installed a fresh copy of Windows 7 Pro x64 and I need to select my user account every time.

I've done some homework, I know about the:

Go to Start > Control Panel > Administrative Tools > Local Security Policy

Select Security Settings > Local Policies > Security Options

Look for "Interactive logon: Do not display last user name"

This security setting determines whether the name of the last user to log on to the computer is displayed in the Windows logon screen.

If this policy is enabled, the name of the last user to successfully log on is not displayed in the Log On to Windows dialog box.

If this policy is disabled, the name of the last user to log on is displayed.

Default: Disabled

It is already Disabled! So, What I'm missing here??

  • funny thing is, I just found a computer configured this way, and I don't know how it's done. Computer is not in domain and has never been. Also, it's certainly not group policy (I checked all configured gpedit.msc entries, there are few), and not local security policy (I reset it by importing "%SystemRoot%\inf\defltbase.inf"). It's certainly not dontdisplaylastusername, which existed (tho was =0), yet I removed it by hand to ensure. Here's how it looks: photos.app.goo.gl/G95ncCehwR9Ebbki8 – LogicDaemon Feb 12 '19 at 14:16
  • Interestingly, there are people asking about reversing it, and say it's related to "classic logon" policy option (on Server 2008) social.technet.microsoft.com/Forums/windowsserver/en-US/…. It's not tho, I've tried all 3 modes: Enabled, Disabled and Undefined, with no visible difference. – LogicDaemon Feb 12 '19 at 14:26
4

it can be done done directly on registry by saving the code in a .reg file and executing it

Windows Registry Editor Version 5.00
[hkey_local_machine\software\microsoft\windows\currentversion\policies\system]
"dontdisplaylastusername"=dword:0
| improve this answer | |
1

Now that I've read your post again and read this TechNet again, you need to use Group Policy Editor to enable the Classic Logon.

  1. Click Start, type gpedit.msc, and then press Enter. This opens the Local Group Policy Editor with the top-level Local Group Policy object open for editing.
  2. In the editor, expand Local Computer Policy, Computer Configuration, Administrative Templates, System, Logon.
  3. Double-click Always Use Classic Logon.
  4. Select Enabled, and then click OK.

That should invoke the Logon screen rather than the Welcome Screen. It should remember the last user for you.

| improve this answer | |
  • I was unable to find this option. Win 7 Pro? – Pedro77 Feb 25 '14 at 13:14
  • Missed that it is Windows 7 PRO, so I changed the answer to what I believe may help you. – CharlieRB Feb 25 '14 at 13:25
  • Thanks but I want to display the last user name, and only type the password. Maybe I need to enable the logon screen. – Pedro77 Feb 25 '14 at 13:27
  • 1
    I'm having trouble thinking today. You're right. Let me update it again to the actual piece of the article that will help. Sorry for the confusion. – CharlieRB Feb 25 '14 at 13:30
  • I did that, no changes. :( – Pedro77 Feb 25 '14 at 16:25
1

tl;dr:

reg add "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList\delete_me_to_restore_users_display_on_logon_screen"

Explanation:

so after some googling and messing around I found (thanks to @jonhoo) how it's "done"

Thing is, Windows fails to build user list for LogonUI display if any of keys in HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList don't have at least values with names: Flags, ProfileImagePath and State. Then it falls back to showing only Last logged on user and "Other users" button for manual enter of username.

So, to cause this behavior, just add any subkey to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList without any values and you're good. Remove to restore.

I advise calling the new key some way it's clear why it's there and what it does.

And of course, if you have this problem and want to restore user list, check all ProfileList subkeys and and remove ones don't have these 3 values (usual warning: handle registry carefully and backup before doing this of course, aside from accidental errors there are ways to hide user accounts from logon screen even if list can be read, so if you only have one user for example, and it's hidden using SpecialAccounts, you won't be able to logon after restoring user list, because there won't be any users!).

| improve this answer | |
  • got an autohotkey script to auto-fix profile list when it gets corrupt – LogicDaemon Jun 4 '19 at 9:15
0

On a domain, you can use this GPO setting:

Computer Configuration > Policies > Windows Settings > Security Settings > Local Policies > Security Options > Interactive logon: Do not display last user name

Set to Disabled.

"If this policy is disabled, the name of the last user to log on is displayed."
| improve this answer | |
  • 1
    It is not clear if computer is on a domain. I would assume we have a stand-alone computer and no Global Policies are enforced by a domain admin. "Interactive logon - Do not display last user name" is already disabled(as stated in question). I suppose the answer is already given by @CharlieRB above. – snayob Jan 20 '17 at 3:59
  • That is an old question. I'm using Win10 now and I can't test it. @snayob The computer was on a domain and I don't know why but when I tried CharlieRB answer it didn't work. – Pedro77 Jan 20 '17 at 11:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.