2

My Elantech touchpad won't work correctly in Ubuntu 13.10 (I had the same problem with 13.04). I can move the cursor and left/right click, but the sensitivity is too high, no scrolling, and no multitouch.

Under System Settings / Mouse & Touchpad, I have no touchpad tab.

This is the result of xinput --list

   ⎡ Virtual core pointer                       id=2    [master pointer  (3)]
   ⎜   ↳ Virtual core XTEST pointer                 id=4    [slave  pointer  (2)]
   ⎜   ↳ PS/2 Elantech Touchpad                     id=11   [slave  pointer  (2)]
   ⎜   ↳ ELAN Touchscreen                           id=13   [slave  pointer  (2)]
   ⎣ Virtual core keyboard                      id=3    [master keyboard (2)]
     ↳ Virtual core XTEST keyboard              id=5    [slave  keyboard (3)]
     ↳ Power Button                             id=6    [slave  keyboard (3)]
     ↳ Video Bus                                id=7    [slave  keyboard (3)]
     ↳ Power Button                             id=8    [slave  keyboard (3)]
     ↳ Sleep Button                             id=9    [slave  keyboard (3)]
     ↳ AT Translated Set 2 keyboard             id=10   [slave  keyboard (3)]
     ↳ Integrated Camera                        id=12   [slave  keyboard (3)]

I have tried updating the kernel and installing either psmouse-elantech-v6 and psmouse-elantech-v7 drivers, but nothing helped.

What else could I try? Thanks

4

You probably have a laptop with a newer version of the Elan touchpad.

Check out comment #137 on this thread - download the dkms package and follow the instructions to see if that helps.

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1166442/+index?comments=all

Note that this doesn't seem to work for some Gigabyte notebooks.

[Edit] As requested, the solution from the link above is:

Step 1: Download the following dkms package

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1166442/+attachment/3941591/+files/psmouse-elantech-x551c.tar.gz

Step 2: Run the following commands in the download directory (or adjust the paths accordingly):

sudo dkms ldtarball psmouse-elantech-x551c.tar.gz
sudo dkms install -m psmouse -v elantech-x551c
sudo rmmod psmouse
sudo modprobe psmouse
  • 1
    It would be helpful to copy the solution here and provide the link for reference in case the link goes dead in future – Mokubai Apr 12 '14 at 18:54
  • 1
    Thanks for the answer. I tried that solution, but it made no difference. – Dario Oddenino Apr 14 '14 at 12:37
  • @Maiagallo - sorry to hear that. You might want to post your HW info on the open bug for the subset of users for which the fix doesn't work. bugs.launchpad.net/ubuntu/+source/linux/+bug/1272777 – Jin Hian Lee Apr 15 '14 at 5:16
0

The new kernel ubuntu 3.18 multitouch enabled my ETPS / 2 Elantech Touchpad with zoom photos, vertical and horizontal scrolling with two fingers like in windows 8.1. Tested on ubuntu 14.10 with all updates.

  • In my case I have 3.19rc7 but no luck :( – ruX Feb 4 '15 at 12:09

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.