152

I recently created a free web hosting account on x10Hosting. Let's use www.example.x10host.com as my example domain. Before signing up for the domain, I visited the domain to see if it was available. When I saw that it was, I registered it, and immediately went to go look at it on Google Chrome. I still got the "Domain Available" message, so I tried again in 10 minutes, and still got the still got the message. I tried later in Firefox and got it as well. The next day, I tried it in Internet Explorer, and it worked. I am assuming that I now have an outdated cache of the page stored for both Chrome and Firefox. How can I clear just the cache for that specific page so that it will load normally?

2
  • Same way as in IE "ctrl"+"F5"
    – Ramhound
    Feb 26, 2014 at 2:35
  • 2
    You might want to look into this answer. It solves your actual problem of clearing the cache pertaining to a specific website (which is currently opened) and not the whole browser.
    – RBT
    Jul 19, 2017 at 5:32

7 Answers 7

333

@dwurf Ctrl Shift + F5/R is Hard Reload, doesn't empty cache.

There is a simple way to do what OP wants:

  1. Open Dev Tools by pressing: F12 or Ctrl+Shift+I (or on Mac: Opt+Cmd+I)

  2. Now by just leaving dev tools open, right-click or click and hold the reload button next to the address bar. Now a somewhat 'hidden menu' opens.

  3. Choose: "Empty Cache and Hard Reload"

15
  • and what about history? Aug 24, 2014 at 6:38
  • 3
    Is this still valid, is there a video of how to do step 2. trying it with no avail
    – pal4life
    Jan 20, 2015 at 21:28
  • 9
    This doesn't help if site A redirects me to site B, and I want to clear the cache fo site A. Feb 6, 2015 at 18:45
  • 7
    Dev tool > Network > Check Disable cache Jan 21, 2016 at 7:24
  • 3
    It is critical to know that it clears the entire cache of the browser and not just pertaining to the website currently opened in the current tab.
    – RBT
    Jul 19, 2017 at 2:49
13

Ctrl+F5 reloads the page without using the local cache.

Ctrl+Shift+R also works, but not in IE

Chrome Reference

Firefox Reference

Internet Explorer reference

2
  • @Ramhound Ctrl F5 opens the file browsing window for me. Feb 26, 2014 at 2:43
  • 3
    Cmd+Shift+R on Mac OS X Aug 4, 2014 at 13:07
9

In the Chrome DevTools settings/preferences there is an option under "Network":

Disable cache (while DevTools is open)

You can open that, and reload the webpage without the cache.

I had a frustrating situation where a HTTP redirect was cached, so I couldn't just refresh. Opening the DevTools with the "Disable cache..." option open and re-entering the URL was the only thing I could figure out other than doing into the regular Chrome preferences and deleting the cache there (significantly more difficult)

For the record, having the DevTools open also enables a 3rd option on the refresh button (right-click) context menu:

  • Normal Refresh
  • Hard Refresh
  • Empty Cache and Hard Reload (careful, this clears your whole cache)

There is a good explanation of what these options mean here: https://stackoverflow.com/a/14969509/363701

Its worth noting that clearing the cache does not clear the History.

1
  • No need to open settings (gear icon); there is a "Disable cache" checkbox in the Network menu. ...which I don't quite understand the name of: because if you reenable the cache, cached behavior does not reappear -- as if the cache had been cleared.
    – zylstra
    Apr 23 at 5:32
5
  1. On Chrome, open chrome://settings/siteData

  2. Type example.x10host.com on the Search cookies input.

  3. Click on the trash bin to delete cached data and cookies for that web site.
1
  • 1
    Only this solution works for me on MAC. Thanks a ton.
    – Abu Shoeb
    May 13 at 1:47
1

[Quick Answer]

Dev tool (Ctrl+Shift+i) or in some cases using F12 | Network | Check Disable cache

0

In my case, when developing I made a redirect page, then I couldn't do ctrl+f5 on the page because there was not enough time in the page until the redirection method got executed.

Then, I went to console f12 and then pressing f1 to see the options, disabled the javascript to avoid redirection, and after that I did a ctrl+f5 before enabling the javascript again.

Hope it helps someone.

-2

right-click on reload and click on Empty Cache and Hard Reload

click to see the steps

5
  • 1
    The author is using Windows, your screenshot indicates you are using macOS, is your answer applicable to the author's question?
    – Ramhound
    Sep 22, 2019 at 14:52
  • Thanks for your help!! but the second step of this answer is also saying this Sep 23, 2019 at 5:35
  • I am not asking about another user's answer. I am asking about your answer? Is your answer applicable to this question? If there is a second step, is there a reason, you don't include it in the body of your answer?
    – Ramhound
    Sep 23, 2019 at 8:24
  • Thank you for mentioning this. I thought steps are obvious from the image, but they are not. I should have mentioned that you need to have your dev tools open before doing right click on the reload button otherwise this menu will not be pop out. Thanks again!! Sep 23, 2019 at 12:54
  • 1
    The information in your comment should be in your answer.
    – Ramhound
    Sep 23, 2019 at 15:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.