2

After moving to Windows 8, I can no longer directly input unicode characters into PuTTY session window. Like ą, ę, ć, ń using Alt+<letter> with Polish (programmers) keyboard layout.

  • I have Window -> Translation -> Remote character set set to UTF-8.

  • Typing directly using the physical keyboard connected to the server works.

  • And, what is strange, pasting a text with these letters into PuTTY works, too.

  • The server is using UTF-8. Here, ąęółśćżźń is being pasted:

    m@debian:~$ echo ąęółśćżźń > x ; file x
    x: UTF-8 Unicode text
    m@debian:~$
    
  • Pressing e.g. Alt+x, that normally renders ź, in PuTTY window results in a normal latin z. Here, żźżźżź is being pasted:

    m@debian:~$ echo żźżźżź | md5sum
    1ff31403a1089c590ed55d42cdcd0f3e  -
    m@debian:~$
    

    Here, żźżźżź is being typed:

    m@debian:~$ echo zzzzzz | md5sum
    cd519e63e450d863e5ee02814bae016d  -
    m@debian:~$
    

    And here, a plain zzzzzz is being typed:

    m@debian:~$ echo zzzzzz | md5sum
    cd519e63e450d863e5ee02814bae016d  -
    m@debian:~$
    

    Same sum.

  • The only letter with a diacritic that is typable is ó (which is also present in latin1 charset).

  • This same exact executable does work on Windows 7.

My guess is that Windows 8 is somehow deciding that PuTTY is unable to process typed (?) non-latin1 characters and it changes them on-the-fly to their latin1 counterparts.

What can be done?

1

Setting "Language for non-Unicode programs" as suggested in https://superuser.com/a/497880/214569 helped.

0

Accepted answer didn't work for me!

I had changed PuTTY's font previously. The only change that I needed was reverting it to Courier New (in Window -> Appearance).

enter image description here

Also choose 'UTF-8' in Window -> Translation.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.