15

Opening the command prompt ("cmd") on Vista into full screen causes the application to take up 100% vertical space, but only about 50% horizontal. Is there not a way I can make this fullscreen? If it's simply not possible, what is a good replacement?

  • I wonder about the technical reason of the removal. – neverMind9 Jul 9 '18 at 15:02
8

Found this trick somewhere on "The Internet".

  1. Open cmd
  2. type wmic.
  3. Double click the bar to maximize the screen.
  4. Type exit and press Enter.
  • Great one....!! – keenUser Jun 23 '15 at 10:03
6

Not really an answer to your question, but I just wanted to say ALT+ENTER works again in Windows 10 (since Windows 7 it didn't). With this you can really make it fullscreen. (I can't post this as a comment yet)

3

This article explains how to do it in Vista

In short you need to specify the screen resolution manually in the Display Options.

Replacement? Powershell of course.

  • Powershell won't go into fullscreen either... – Sampson Jul 17 '09 at 15:57
  • @Jonathan - ACtually you can according to this thread: serverfault.com/questions/21367?sort=newest For some reason Powershell is toast on my Windows 7 so I can't confirm right now :( – BinaryMisfit Jul 17 '09 at 16:01
  • Strange. I'm using Powershell v1.0, but don't see any options for Fullscreen. I'm downloading v2 CTP 3 now. – Sampson Jul 17 '09 at 16:11
  • Other than playing around with fonts, I don't see a way to get PS fullscreen. :-( – Brian Knoblauch Jul 17 '09 at 16:58
3

For a replacement, you could look at Take Command, it has both a normal console replacement, and a windowy tool where you can open multiple tabs with individual console sessions.

Take Command

You can of course turn off all those extra things so that you only have the console part.

2

Umm.. If you have Vista(i have 7) you could install the graphics driver for XP in XP compatiblity mode under Vista. Then, it will install the same - for XP, but you lose Aero interface. And then, you get the amazing Fullscreen mode in CMD!

PS:This will eventually work, i am responsible for any damage or poofs that crush your graphics. If such happens, please tell me. I will help you or if i don't know how to restore, you must stay in this poof or reinstall vista driver. Crushed.

2

It’s a graphics driver issue. Vista uses hardware acceleration for the desktop, which is why the graphic card cannot switch to text mode (the system would lose track of the desktop). If you have an older VGA that doesn’t support Direct X 10, you should be able to use fullscreen text mode.

  • it's not the real reason. The terminals in *nix also run in fullscreen graphics mode without problem. "Fullscreen" here doesn't mean text mode like you thought, but a window that covers the whole screen. DOS/V for Japanese also fakes text mode in graphics mode. cmd in Windows 10 also support fullscreen without changing to text mode – phuclv Sep 15 '18 at 4:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.