14

I'm using MS Word 2010 to write a document. I have a table with a header row (indicated as such, 'Header Rows Repeat'). Now, the table starts pretty low on the page, and Word decides to break it exactly after the header row. It really shouldn't... I don't want to altogether prevent tables from breaking across pages, just to prevent the situation in which I have an orphaned header row at the bottom.

Can this be done?

I'm also interested in an answer applicable to Word 2003 and 2007.

16

Highlight all the content inside the header row and the second row and go to Paragraph properties and check Keep with next. This should stop the header row and the second row from being on separate pages, while it still allows the rest of the table to freely break across pages.

  • That's twisting the semantics of 'Keep With Next', which shouldn't affect the next table cell IMO, but it works. – einpoklum Feb 27 '14 at 8:04
  • I take it as affecting the paragraphs which are contained by the cells, and not the cells themselves (note that a valid cell even when empty must contain a paragraph). – Adam Feb 27 '14 at 8:32
  • 1
    Thankyou +1. In Word 2010 (14.0.7181.5000), one just needs to select the top (header) row (and not explicitly the text within it, and not the second row) before adjusting the paragraph properties to keep with next. (Presumably setting this on the second row would keep the first three rows together, not just the first two). – Sepster Jun 26 '17 at 2:55
1

Per @Adam's answer, the "Keep With Next" option needs to be set on the header paragraphs.

I would recommend setting up a "Row Header" style that encompasses this paragraph option, as well as any other visual formatting, that can be easily applied to the top row of all your tables.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.