I have searched the web and spend hours trying to figure out this strange behaviour of Outlook 2010,

My client has this problem with her Outlook 2010 since yesterday, the mails download but do not appear anywhere in Outlook 2010. The download bar shows mails are downloading, mails are then removed from the server, but no where to be found in Outlook.

There's 1 email account, and then 5 PST files of which one belongs and is linked correctly to the email account.

I can also search in outlook for the mails, but nothing shows up, I also re-indexed Outlook and still can't find the mails. I tried sending a mail which sends fine, the mail is also stored in the sent items, so the problem is only when receiving emails

The solutions I've tried and found on http://answers.microsoft.com/en-us/office/forum/office_2010-outlook/outlook-2010-receive-messages-but-cant-see-them/dabdc9f1-c46b-427f-be2f-f42b56d31171?page=4 don't help with my problem, I tried the following solutions on the link above

File>Account Settings>Data Files>Select the email you want to see the emails from and click "Set as Default" then restart out look and the inbox should have your emails in them if not hit send and receive.


In Outlook 2010, Go to "View" tab, Under "Change View" change the Views, that will reset the settings you have.


More on the filter solution. If you are not showing a "filter applied" indication in the lower left corner, try this. Highlight your inbox and select the view tab at the top. Next click on View Settings on the ribbon and select Filter. Select the Advanced tab at the top of the window and if you see a filter set under the Find items that match these criteria then remove it. Click OK out of all the screens and you should see your phantom e-mail appear in your Inbox. Hope this helps someone!

Also tried to run outlook /cleanviews with no effect

No anti virus system is installed, so that can't block mails

Operating System: Windows 7

Outlook : MS Outlook 2010

Any advise help would be highly appreciated, the client also can't afford to loose the mails, so deleting accounts etc is risky.

  • 1
    No antivirus system is installed? You might want to start there. Verify the system is clean of viruses and malware before chasing your tail on this problem. You may want to check out How do I get rid of malicious spyware, malware, viruses or rootkits from my PC?. – CharlieRB Feb 26 '14 at 20:06
  • @CharlieRB - Thank you for raising the point - Yes will have a look, if the system is clean, what else do you suggest – Roland Feb 26 '14 at 20:10
  • Have you tried using System Restore to a date prior to yesterday? Is this Outlook 2010 or 2007? You've referenced both. Also, what type of connection? Is this Exchange or POP/SMTP, etc? – CharlieRB Feb 26 '14 at 20:18
  • @CharlieRB - Totally forgot to mention, it's POP3 port 110 and SMTP port 25, haven't tried system restore, if I perform a System restore will the Ghost mails / data the client received today be lost? – Roland Feb 26 '14 at 20:24
  • System Restore should not effect the data file for outlook. "System Restore can return your PC's system files and programs to a time when everything was working fine, potentially preventing hours of troubleshooting headaches. It won't affect your documents, pictures, or other data." per Microsoft – CharlieRB Feb 26 '14 at 20:27

This worked for me with Outlook 2010.

1) In the left hand navigation pane, click on (highlight) the .pst file where the "missing" emails should be showing. Or, if the emails are just "missing" from a folder or subfolder, click on that folder or subfolder.

2) Click on the "View" tab on the top of the Outlook window.

3) On the far left side of the ribbon in the "Current View" section, click on "Change View."

4) There should be 4 options:

 Hide Messages
 Compact
 Single
 Preview

5) "Hide Messages" is probably the option presently applied, so click on the option you would prefer instead, and your emails should appear in your email window in the format you have just selected.

6) If "Hide Messages" does not appear as an option, click on any option other than the one presently applied and let the drop down box disappear. Your emails should appear in the email window in the format you have just selected. Then click on "Change View" again and choose your original format (assuming that this format is still what you want), or choose another option altogether. Your emails should now appear in the email window in the original or newly-selected format.

I was able to find my hidden emails by selecting Change View, selecting Preview, after which the hidden messages appeared in the preview list.

I then went back to compact view, which is my normal view setting. Hope this helps.

try this it worked for me:

go to account settings. choose Change Folder under Personal Folders\Inbox make sure that it points to the correct .pst file because in my case fir some reason it was pointing to the dfault .pst file not my imported .pst file that I set in the Data Files tap. hope this helps.

I just had this issue with Outlook 2010. All you need to do is delete the outlook profile and recreate it. Open up control panel > Mail > Delete your existing profile by selecting profile name and remove/delete. Open up Outlook and create the profile again.

Hope this helps.

this it worked for me too:

go to account settings. choose Change Folder under Personal Folders\Inbox make sure that it points to the correct .pst file because in my case fir some reason it was pointing to the dfault .pst file not my imported .pst file that I set in the Data Files tap. hope this helps.

I had the same problem as you and I have solution that worked for me.

For some reason email password was the problem. I could send email, but I couldn't find received ones. Here's how to fix :

  • Go to cpanel
  • Email accounts
  • Password and Authentication
  • Change password for that email account.

Use new password when you are creating new email account in outlook for that email account.

Turn off or disable all your Rules. It solved emails going to ALL MAIL and bypassing INBOX. Outlook rules are a pain. Thunderbird has a much easier way to create rules.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.