0

I have a word document that I am using as a template and I intend to flow different text through it dynamically, so I can't apply any paragraph-level formatting. In any case, I am running into a puzzling issue: when I place a narrow table on the left side of the page and then wrap text around it to the right, the indentation scheme of bulleted lists breaks. If the bullet wraps to two lines, the second line of the bullet wraps all the way to the left-most margin instead of hanging at the same spot where the first line begins.

I've tried adjusting the margins, but it messes up the whole document. Even paragraph-level margins (which are not technically feasible, given then intended use of this template) can't be arranged to make the text appear properly. The only thing that works is removing the table that the text is wrapped around, which isn't an option because it is necessary for the desired formatting.

  • Can you add a screenshot of the problem? – Adam Feb 26 '14 at 22:29
  • I am unable to add an image because my account is too new. I have uploaded it here: i.imgur.com/Jvge2bL.png – develdevil Feb 26 '14 at 22:55
1

I was able to recreate your issue, and I think you're correct-Word is trying to wrap the hanging indent back to the original left margin. I don't think you can correct Word's behavior here (without resorting to VBA or switching to a better layout engine like Latex). Here's a possible work-around:

  1. Insert your text and bullet formatting (but not your table).
  2. Where you want your table (in relation to your other text), insert two continuous section breaks-one at the beginning of your table's location, the other at the end.
  3. Format your new in-line section to 2 columns.
  4. Insert a column break at the beginning of your bullets, to push all of your bullets to the right column.
  5. Insert your table in the new, empty right column.

I'm not sure how well this will work in your dynamic text environment, but it may get you one step closer to a complete solution.

0

The only solution I'm aware of that addresses the dynamic flow issue is to use MS Publisher, which is specifically designed for that purpose and makes it a snap to flow text around objects with any margins you want.

If you have one of the Office 'Premium' or 'Plus' packs, you probably have it though, like many, may never have opened.

0

Here are two easy ways to fix that.

  1. Remove the table wrap and insert an additional column to the right. Paste your text into the second column and remove the borders.

  2. Paste the text into a text box and remove the borders.

I tried both methods and the bullets kept their formatting. I'd avoid table wrapping in Word, it's more trouble than it's worth.

Per your comment, the less elegant solution would be to highlight the bulleted text and move the hanging indent indicator on the ruler over to the desired position:

Ruler before enter image description here

Ruler after enter image description here

  • This comes close, but the problem that the table is solving is that, after the first page, the text takes up the full width of the page. Since it is supposed to flow into this layout dynamically, I can't specify a place in the text where it will stop being 2 columns and start being 1 column. By having a table at the front of the document that the text wraps around, the text automatically flows into full-width. – develdevil Feb 27 '14 at 21:31
  • See my suggestion above. – Karen927 Feb 28 '14 at 19:15
0

In my experience, if you wrap the text at the left of the table, then your bullets will retain the proper settings. This is true for wrapping text around figures, too.

Aesthetically you may prefer text to the right. But to save yourself headaches and extra work, just wrap the text to the left.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.