3

I have a Logitech Touchpad T650 attached to a server running Windows Server 2012 R2. I use this machine as my regular computer, and there is another user who connects to it remotely (and occasionally comes to my desk to use it if I am not there). This has worked without any problems for some time.

Recently, I noticed that 2-finger tap (for right-click) did not seem to be working anymore. On further inspection, I found that the right-click context menu would come up for an instant and then disappear, but I still had no idea what was causing the problem. Then, I noticed that anything I pasted in PuTTY (using right-click to paste) was appearing doubled. From there, I realized that the cause of the whole issue was the fact that SetPoint was running twice, once as me and once as a Remote Desktop user.

However, ending the other user's SetPoint executable in task manager didn't really solve the problem - now the TouchPad won't right-click at all. I know that I can solve this problem by restarting the computer, or just logging all users out and logging back in myself, but that is a not really a solution - the problem will just happen again. I also cannot just have SetPoint start only for me or only for the other user because there are legitimate use-cases where only one or the other of us will be logged in on the computer and then whichever of us is at the desk will not be able to use any of the Touchpad features that SetPoint controls.

If I remember correctly, this was not a problem in the past, though the Logitech software on this computer has not been updated since its original install as far as I know.

How can I solve this problem and get my Touchpad back to the way it is supposed to work?

1

Have you upgraded the T650 firmware since February 2014? With the upgrade you might be able to use it without SetPoint - which seems to be your problem point.

It added built-in support for clicking etc so it could be used without a driver (e.g. on Linux). I've tested that it only worked for pointing and scrolling (but not clicking etc) on the Raspberry Pi "Raspbian" Linux before the upgrade, and that clicking, right-clicking etc works fine after the upgrade.

I'm also using it on Windows 8.1 right now without Set Point.

  • The firmware update does help for the right-click issue, but running without setpoint means that "Natural" two-finger scrolling (in the same direction as the content, like a touchscreen) doesn't work - they still haven't included that by default. – Moshe Katz Jul 10 '14 at 16:55
  • Yes, so I think your only option is to either accept that you can't use SetPoint, or take it up with Logitech. I see there is a recent version (6.65.62, 2 Jun 2014) you could try. Users are talking about similar problems in a forum post - you could try one of the suggested solutions, but not everyone is happy: forums.logitech.com/t5/Mice-and-Pointing-Devices/… – Nick Westgate Jul 11 '14 at 4:56
1

I too have had this problem, and have a workaround which isn't great, but am wondering if I can improve it.

Open the task manager and kill all the 'Logitech SetPoint Event Manager' instances. Then you can run

C:\Program Files\Logitech\SetPointP\SetPoint.exe

I've made a shortcut to this on my desktop because I do it so often.

This isn't ideal, but it does mean you get all the touch facilities without having to reboot. I'm thinking of writing a script that automatically does all this on logon/unlocking - I'll let you know if I succeed!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.