0

I've created a service using Automator in Mac OS X 10.9 (and earlier in 10.8) to copy full path names of selected files and folders in Finder. Also I've assigned shortcut for this service in system preferences. But shortcut doesn't work when I select single folder. Shortcut works for many selected folders and files. Also it works for single selected file. But for single selected folder it works only when I run service from Services menu without using assigned shortcut. I've tried different key combinations for shortcut but behaviour for all was the same: selection box for single selected folder changes its color from blue to gray and no action to run service.

2

I have noticed a few bugs since at least 10.7:

  1. Services that receive files and folders or only folders as input are never shown in the services menu when a single folder is selected in column view. It only applies to column view and not to list view or icon view.
  2. Sometimes the shortcuts for services don't work until you hover over the services menu from the menu bar, or for example run a service from the services menu once. It seems to apply to all applications and also to services that receive no input.

Are you sure it's not a case of the second bug, or does the shortcut actually start working after you run the service once from the services menu?

Could you maybe assign a shortcut to an AppleScript instead of creating a service? I have used FastScripts to assign a shortcut to this script:

tell application "Finder" to set s to selection as alias list
if s is {} then return
set out to {}
repeat with f in s
    set end of out to POSIX path of f
end repeat
set text item delimiters to linefeed
set the clipboard to (out as text)
| improve this answer | |
  • Thank you for detailed answer! I tested your suggestions, so in my OS following behaviour: my service is always available under Services menu in any finder view, but keyboard shortcut doesn't work in column view - this view mode I use very often so the bug is critical for me. I will try your suggestion with AppleScript or FastScript, thank you. – C0DEF52 Mar 6 '14 at 6:25
  • I hovered over the services menu from the menu bar, and it started working, thanks! – david-hoze Sep 18 '17 at 8:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.