I'm trying to delete a folder in Windows 7 and get a perplexing error message: "Could not find this item: This is no longer located in G:\Graphics. Verify the item's location and try again.

I can see the folder -- I can find it. I just can't delete it.

I also get a second error message (sometimes) when I click on the folder: G:\Graphics 2009-11-17 refers to a location that is unavailable...this information might have been moved to a different location.

I'm using Windows 7; this folder is on an external hard drive. I've emptied the folder (there were items in it); I've scanned that external hard drive for errors. Trying to rename the folder yields the same enigmatic error message.

Is there a way to delete this folder?


7 Answers 7


Open Command Prompt, use dir /x to get the 8.3 name of the folder which cannot be deleted, and then use rd with the 8.3 name of the folder, and it should be gone.

If this doesn't work, ensure first that the folder is empty.

  • 1
    Thanks, this worked. Not only did I have to rd with the 8.3 name, but there were a bunch of hidden sub-folders with content which had to be deleted first: 'del /s /f /q .' and then 'rd /s /q eight.three'.
    – Tom
    Jul 13, 2010 at 10:07
  • You may have to rename the folder first and then delete it. So first open a cmd and type cd then drag the parent folder in cmd (this will add the path), then press enter. Then type dir /x and enter. Then type ren Folder~1 newname (replace Folder~1with your folder 8.3 name whici you can find in the long list created by the previous command), press enter. Finally type del newname and press enter src= answers.microsoft.com/en-us/windows/forum/windows_8-files/…
    – MagTun
    Jun 29, 2019 at 8:33

You can try Unlocker if you experience these kind of issues in the future. Windows is known to lock certain files/folder and refuse access to edit/delete them from time to time; Unlocker is a handly little program that can help rename/move/delete unresponsive files/folders.

  • 1
    +1, Unlocker's a great tool. It's come in handy for me many times over the years. Mar 13, 2013 at 2:07
  • 1
    This worked, but watch out for bundled malware that's default-checked in the installer. Aug 14, 2015 at 16:18
  1. Download 7zip
  2. Browse to folder
  3. Right-click rename (successful)
  4. Close 7zip
  5. Browse to folder > right-click delete
  • I finally had to delete the file from MacOS to but it was not possible before using this trick
    – lauhub
    Feb 6, 2019 at 1:32

yes. Boot into Linux using any of the live CDs, I would recommend Ubuntu and delete that damn folder

  • 1
    Haha, I remember creating a ton of nested directories one time in Windows to mess with a friend, then I couldn't delete them from Windows. I think I ended up doing it in Linux. Nov 18, 2009 at 20:05
  • 1
    Yeah...I virus clean all my suspicious thumb drives in Ubuntu before shoving them up in Windows
    – detj
    Nov 18, 2009 at 20:24

Try this:

Do a dir /x /ad to get the 8.3 name of the folder (it will look like docume~1), then do a rd folder* /s (you may even truncate it more like rd fol* /s if there are no other directories with similar names).

If this does not work, the run chkdsk /f (maybe a couple of times even, but check your Event Viewer>Windows Logs>Application Log to see if there are still a lot of errors. http://www.sevenforums.com/tutorials/96938-check-disk-chkdsk-read-event-viewer-log.html screenshots 6 or 8). Then try the rd command with the 8.3 again as above.


Do not forget if the file type has been corrupted, the extension may not appear in the 8.3 name, if for example you have something like this:


and the one missing its extension is the one you can't delete, use the del command and the file name and add four spaces, then hit Enter.

For example:

del FILENAME__________

The ____________ at the end there is just to show the four spaces added.

This just worked for me on a file that was corrupted during download.


Try restarting your computer, and then deleting the folder.

When you restart your computer the folder might even be gone. It might have already been deleted, but Explorer was showing a cached image.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .