0

I have an Intel DH67CL motherboard, booting from a regular HDD. I then installed Windows on a new SSD after disconnecting my old drive.

When I went back to reconnect my old HDD, the BIOS boot menu will not let me select the new SSD as the preferred first boot option.

The BIOS settings only shows me the two hard drives, but I can't choose the new SSD as the BIOS prefers the old one.

How can I let the BIOS understands to load from SSD?

  • 2
    The BIOS doesn't move your OS to the new drive for you. Is that what you are asking about? Your question is not easy to understand. Please edit your question to clarify. – CharlieRB Feb 28 '14 at 19:46
  • Ensure that besides the "Boot Order", that there isn't also a separate entry for HDD order. – Ƭᴇcʜιᴇ007 Feb 28 '14 at 21:15
1

I suppose this is due to Intel Fast Boot Technology. When booting speed is set to fast, the BIOS will try to boot from the drive attached to a specific port and ignore settings saying otherwise.

If that's the case, interchanging the two drives' SATA cables should suffice.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.