I get the following dialog whenever Windows Firewall (on Win7 SP1) catches a new program trying to get network access:

enter image description here

Why does it allow public by default but not private? Isn't public the less secure one? Shouldn't it be the other way around? Can I change the default?

1 Answer 1


It's whichever network type you are currently connected to. The goal is to let the user allow without having to manually pick the type, while minimising the exceptions (which is why it doesn't allow both automatically).

You are probably connected to a network designated as public at the moment. You can change that in the networking control panel.

Incidentally, if you were connected to a domain, there would be a third option.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .