2

When I got my Surface Pro 2, I loved it, and everything seemed to work flawlessly, until, wait for it, windows updates...

The issue that I am having is the following, I primarily use the TC (TypeCover), as the Pro is an out-of-office laptop replacement for me, that I can still use to do whatever I need, but there are times when I will flip the cover, and use the system in tablet mode.

The problem is that even when the TC is attached, any text field I click on, causes the OSK (on screen keyboard) to appear, as if I was running the system in tablet mode. As soon as I press a single button on the TC, the OSK is dismissed.

When I first got the system, this was NOT the case, and it functioned as it should, where the OSK will only appear if the TC was not present.

The biggest problem that I am having is the fact that the OSK causes the windows to be resized. Maximized windows will be shrunk, and stretched to their previous state, however a window that is not maximized will stay in its shrunken state, after the OSK has been dismissed.

Below are pictures that show what is happening.

Has anyone else experienced this issue? And is there any way to fix it? As you might imagine, having spent a pretty penny on a device like this, it it quite an annoying bug that needs fixing. I have been dealing with this issue for about 3 months now.

2
  • 1
    I have experienced this exact issue recently using the 'Touch' cover. However, in a test just now I found the problem existed when using Chrome, but not IE11 which worked fine without displaying the onscreen keyboard.
    – harunahi
    Mar 4 '14 at 3:43
  • Oooh.... I just played around with some programs, and it seems as if this is a Chrome issue..... :(
    – Matt Clark
    Mar 4 '14 at 3:46
1

I've done a bit more reading up on this and confirm that this is caused by a bug in recent releases of Chrome.

A solution seems to be to temporarily disable the on screen keyboard when using Chrome.

The bug is reported along with details of a temporary fix here: https://code.google.com/p/chromium/issues/detail?id=330938#makechanges

However, I tried this

  • Swipe from the right to bring up Search and type in 'Services'.
  • In the Services dialogue, scroll down to Touch Keyboard and Handwriting Panel Service
  • Either right click on it or double click/tap and then Stop the service.

And unfortunately it doesn't seem to work. The keyboard still appears. Maybe Chrome just restarts the service.

So, not much of an answer, but:

  • Hope Google fix this in the next version of Chrome
  • Use IE11 (I have begun to like it, but still need to use Chrome for certain things)
  • Use Tab to navigate to a field. This doesn't bring up the on screen keyboard.
  • Use full screen windows to avoid the window sizing issue and just ignore the on screen keyboard which disappears when you start to type on the external keyboard.
1
  • I guess that works for now... I wish there was a real fix... :(
    – Matt Clark
    Mar 11 '14 at 2:25
1

There is a way to prevent this on the Surface Pro 2. At the top of the keyboard screen next to the "x" for close there is a button that makes the keyboard sit in front of any app. When you click this, the key board gets slightly less wide and will not change the size of Chrome.

1
  • I actually found this quite useful, and have been using it in that mode for a while. Still not a fix, but thanks for pointing it out.
    – Matt Clark
    Jun 12 '14 at 2:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.