61

I have a problem with the sound quality of a pair of Acoustic CHP600BT Solutions Bluetooth Headphones - Black.

When I connect these headphones to my phone (Samsung S2 plus), the sound quality is perfect, but when connecting to my laptop the sound quality is bad with static.

I use Windows 7 Ultimate. I reinstalled all drivers and searched the problem on Google, but found nothing.

  • 4
    Is there any chance you're using the headset profile instead of the A2DP profile? – Spiff Mar 3 '14 at 18:07
  • How to check that? – iCoRe Mar 3 '14 at 18:08
  • do you have another bluetooth speaker of some kind to test? – Keltari Mar 14 '14 at 14:43
  • Maybe your card is bad in your laptop. – juniorRubyist Aug 6 '15 at 1:39
  • what works for me is disabling all services except Audio Sink – Dasser Basyouni Apr 28 '17 at 14:25

15 Answers 15

80

I had the EXACT same problem and fixed it from the above comment like this:

  1. You have to uncheck “Handsfree Telephony” from the “Services” setting on your Bluetooth device → “Control Panel” → “Hardware and Sound” → “Devices and Printers”.  Select your device and right-click, open “Properties”, then go to the “Services” tab and uncheck “Handsfree Telephony”.  I just fixed it like that.

    This works on Windows 7 and Windows 10.

    Handsfree Telephony

  2. Mark it as your default device in “Control Panel” → “Hardware and Sound” → “Change system sounds” → “Playback”.  (It may be good enough to go to “Control Panel” → “Hardware and Sound” → “Sound”.)  Select your Bluetooth device and select set defaults.

    Default Audio Device

  • I had the same problem and this was the right path to solve it! as a matter of fact it sounded like a phone headset before of this: low bandwidth, no basses, "electronic-like" voice.. but now it works like a charm =) – Luke Dec 6 '15 at 22:03
  • 5
    Just to confirm this works for Windows 10 as well. – jackdh Jan 12 '16 at 22:05
  • 1
    Something similar worked for me in Windows 10 for my Bose SoundLink headphones - I noticed there were two separate devices listed under "Playback devices": Bose OE SoundLink Hands-Free, and Bose OE SoundLink Stereo. The Hands-Free was selected as the default, and changing it to the Stereo immediately fixed the issue - audio quality instantly got better. – Craig Otis Dec 31 '16 at 18:18
  • 2
    Disabling handsfree profile will not let you to use mic afterwards. – Aman Sep 28 '17 at 12:12
  • 2
    By this way, you cannot use mic and stereo headphone simultaneously. – Aman Oct 5 '17 at 10:17
27

I just ran into this issue, turns out I had two profiles, Hands Free and Stereo, I was using hands free, changed to stereo and this fixed the issue:

Hands free vs Stereo

  • 1
    Thanks! I totally missed this, I have the same choice. This is a much better solution, because it allows you to use either telephony OR high quality audio as the situation allows - rather than completely disabling that functionality at a system/driver level as others have suggested. – darkbluesun Oct 15 '16 at 9:07
  • I had the same thing, until one day, the stereo profile disappeared. Had to use the option where you disable handsfree telephony from the hardware & sound -> printer & devices -> [select device] -> Services - for this to even be visible again. – Kalec Mar 18 at 12:19
10

At random times when I connected my bluetooth headset (on Windows 7), the sound would get really bad.

After extensive research on Google, I found out that this seems to be because the Bluetooth protocol as it is right now does not provide sufficient bandwidth for the headset to use the microphone and high quality audio at the same time. This could be consistently proven when trying to use Skype with my bluetooth headset functioning as a microphone and audio output at the same time. The audio would get crappy 100% of the time.

For some unknown reason, sometimes when I connected the headset to my computer, the sound would get horrible, even though I was not using its mic. The fix I found was to simply give up using the headset's mic altogether. To do so, I disabled the bluetooth services for everything other than the audio output. This is how I've done it:

  1. Go to Windows' devices
  2. Find your headset, right-click it and select "Properties"
  3. Go to the "Services" tab and deselect everything but "Audio Sink" (with this, I believe we are disabling all bluetooth drivers but the audio driver, making no other item mess with the bandwidth - beware, if something you'd expect from the headset stops working, it could be because of this)
  4. Reconnect your headset (not 100% sure this is necessary, but it might be)

The steps described above worked for me, but I don't have enough knowledge to state that they should work for others. I hope they do. Good luck!

  • 1
    impguilherme: You don't have to uncheck the Handsfree telephony. This will disable the microphone too. The reason why it is bad, is because the signal is split between microphone and headset. If you set the default playback to be the stereo version of the device - it should work fine. Hope this helps. – elika kohen Apr 18 '16 at 18:49
  • This advice did it for me, everything above didn't work. Sudenly, I have awesome sound, thank you a lot for sharing this. – Tomáš Zato Jun 13 '16 at 20:48
  • It's funny how in the Spanish version of Windows "Audio Sink" becomes (translated back to English) "Audio Sync" :S – Azurlake Jul 10 '18 at 21:49
7

You have to Uncheck "Hands free telephony" from the services setting on your bluetoth device. I just fixed like that.

  • 2
    Welcome to SuperUser. Your answer would be even better if you edit and expand it with an explanation as to why your solution fixes/addresses the OPs question. – Twisty Impersonator Jan 4 '15 at 1:49
  • This solved it for me. As to the "why", I don't think anyone knows... – Ian Kemp Jul 29 '16 at 13:27
6

Here is an easy fix of this problem

Open playback devices- click on headphones - properties - click on advanced tab on the top - uncheck "allow applications to take exclusive control of this device "

It should take care of your problem.

  • 1
    That solved my problem! thanks a ton for sharing. – 5A7335H Mar 6 '16 at 12:37
5

Had the EXACT same problem with my Energy Sistems BT8 Headphones and My Ideapad Y580. But managed to solve it on my own. The source of the problem seemed to be a faulty Bluetooth driver that somehow managed to mess up the protocol that the headphones work with. I removed the device ( Headphones ) from my computer thus removing any driver that it installed during the pairing, removed the Bluetooth driver on my laptop, then installed the Bluetooth driver via Microsoft driver finder, paired the headphones again and allowed the Microsoft to install the drivers it needed and voila ! Everything is working perfect now. Great sound quality, clear sound with no background noise or CB radio like noise, and hell of a great bass.

4

The solution for me was to disable the headset microphone (from the Recording devices menu), disconnect, and reconnect again. So now I am using the headset only as a playback device and the sound is crystal clear.

P.S: I am using Audionic Blue-Beats B800 Bluetooth Headset.

1

My cheap bluetooth speakers were playing what sounded like music through a telephone. I went and clicked on the "device" and clicked "services" then waited for the operations to load and clicked on "listen to music" and also clicked disconnect on "forward VoIP calls to HandsFree" and now it sounds exactly right.

1

Control Panel - Sound - Headphones Properties - Enhancements
Check Disable all enhancements checkbox

I am using laptop with Windows 10 and Sony SBH54 bluetooth headset

0

I had a similar problem to you.

I have a cheap mono BT waterproof speaker and got a cheap Bluetooth USB dongle off eBay for my Windows 7 Ultimate PC. The speaker sounds great with my Samsung S3.

After plugging in the dongle and waiting for the drivers to SLOWLY install, i was able to select the Bluetooth Mono Audio device (right click Windows volume button in tray, Playback Devices, right click the bluetooth profile/device and "Set as Default Device") but that profile was limited to 8 Hz and couldn't be changed. Audio sounded really bad from iTunes.

Then i changed to the Bluetooth Audio Renderer (Stereo Audio) device profile and i got to choose between 44kHz and 48kHz :)

Just a note for iTunes users, you need to make sure you right click the bluetooth profile/device and "Set as Default Device" which will route all of your computer's audio to the bluetooth speaker/headset.

Extra tip - make sure your BT speaker/headset is freshly charged. Mine ran out of battery while i was testing, this is why it sounded even worse with lots of noise as i was initially testing it.

0

SOLVED: Other Bluetooth-connected devices are the cause. They may be interfering/using too much bandwidth.

Before going on to other solutions given here, simply try disconnecting your Bluetooth mouse and/or keyboard while music is playing to your headset. The result will be instantaneous!

I had this same problem and tried all the solutions given in this forum without any result (including uninstalling/reinstalling the Bluetooth drivers which is always unsettling).

However, after reinstalling the BT drivers, when reconnecting my devices, I decided to reconnect the headset BEFORE my BT-connected mouse. Lo and behold, the headset sound was crystal clear. Then I reconnected the mouse, and the issue restarted.

Also, one of the solutions give is to disable the Hands-Free profile from the Sound settings. This will have no incidence on my solution; both profiles work just fine. My problem was really just the mouse.

-1

even ifs marked as your default you need to click on headset as default then click your bluetooth device as default again. For whatever reason it fixed my issue. So even if it is set as default change it then change it back. Worked for me.

-1

I know this is older, but this worked for me which bit-rate was extremely low (modem quality). My headphones have a mic so that I can answer my cell from them. I simply disabled the headphones as the default recording device. After that, i turned my headphones off and reconnected them. I set the default playback device to the headphones. I then restarted my music application and everything is fine now. Haven't had problems since.

-1

I went into the services for the bluetooth headset and checked the box for "Audio sink". This forced Windows to install a Stereo version of the device driver- it only had a mono version previously.

Now I had 2 drivers for the same device, so I disabled the Mono version and was prompted to reboot.

After the restart it sounds near perfect.

-1

I fixed this problem by right clicking the sound icon that's on the task bar in the right-hand corner. Then clicked on troubleshoot sound, and selected the audio render. It applied a fix of setting Bluetooth audio render as the default sound device and then the sound was Crystal Clear.

  • Did you have the same headphones? If not then the troubleshooting fix probably wouldn't work the same for him. – Insane Nov 20 '15 at 4:58
  • Do you have Windows 7?  I don't have "Troubleshoot Sound" on my sound menu. – Scott Nov 20 '15 at 5:23

protected by Community Dec 25 '15 at 7:30

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.