Alright so I attempted to install Xubuntu on my laptop twice. The first one I cancelled accidentally; the second one worked. The end result is the following disk structure:

/dev/sda1 - System
/dev/sda2 - Windows 7 (1)
/dev/sda3 - Windows 7 (2)
/dev/sda4 - extended (for ubuntu)
    /dev/sda7 - working Xubuntu install
    /dev/sda5 - skeleton Xubuntu failed install
    /dev/sda6 - linux-swap

I inspected the failed Xubuntu installation partition and it is pretty much a skeleton of an installation; the root fs folders are all there but empty.

What I want to do is delete the sda5 failed partition and merge it with sda7 because I am running low on space in Ubuntu.

The problem is, when running GParted and attempting to delete sda5 I get the message "please unmount any logical partitions having a number larger than 5".

How do I bypass this? I do not want to destroy my current Xubuntu installation (sda7) only to merge the failed one so that I have more space. How do I do this? Does it involve putting a GParted image on a USB?


Yes, Gparted can fix this. First delete the /dev/sda5 partition and then expand sda7 to take that space by either dragging the partition end over the now free space or by typing in the new larger size for the partition. Nothing happens until you click apply.

  • yeah the problem is that it doesn't let me, with the error message provided. – Aristides Mar 3 '14 at 22:34
  • Are you not booting up with gparted? In other words, are you running gparted from Ubuntu? – jdh Mar 3 '14 at 22:42
  • yes. just made a liveusb and will try again. – Aristides Mar 3 '14 at 23:19
  • alright, it worked. Had a little mishap with GRUB not being able to find the partition, but I fixed it. – Aristides Mar 4 '14 at 0:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.