24

As discussed in ghacks and slashdot Chrome no longer lets you automatically open downloaded pdfs in your System viewer.

In general, I like using the built-in Chrome PDF viewer, but for some longer and more complex PDF documents I much prefer to use my system PDF viewer (i.e., Skim).

I used to be able to save the PDF and it would automatically open in Skim (once I selected automatically open). Or I could save it and click the icon at the bottom. Now you have to manually download and then select "open in system viewer".

  • Is there a plugin to open the currently opened PDF in Chrome in the system viewer?
  • Is there a way of overriding the behaviour in Chrome to force downloaded PDFs to open automatically in the system viewer? (note that I don't want to disable the Chrome PDF viewer in general)

Update: Note that this question is not about disabling the built-in chrome pdf viewer entirely which is covered by this previous question.

The distinction between the two questions is made quite clearly in this google chrome thread.

8

It appears that someone may have finally figured out how to replicate the original behavior you have been hoping for. By disabling the embedded PDF viewer plugin (bear with me), and then adding PDF.JS, you will have the option of opening a PDF inside Chrom{e,ium} or with the external viewer. The behavior sounds as though it will follow the original behavior:

  1. clicking on a link to a PDF will open the PDF in PDF.JS
  2. downloading a PDF will open with the system viewer

Note: this still disables the default PDF viewer in Chrom{e,ium}, it just replaces it with PDF.JS (the viewer that Mozilla has been developing).

Credit to Michael McFadden.

  • I would rather keep using Chrome's internal PDF viewer, but this is acceptable too. Thanks – Tobia Aug 26 '15 at 13:51
3

Open chrome://plugins/ and disable "Chrome PDF viewer". Solved it for me.

Solution found here: productforums.google.com

  • This is the simplest answer, and work on both Windows and Mac versions. – March Ho Nov 13 '15 at 7:19
  • chrome://plugins/ no longer works with newer versions of chrome. – ChaimG Dec 5 '17 at 22:09
0

Another option is to use your system viewer in Chrome. If you install the PDF XChange viewer plugin in chrome and disable the default chrome pdf viewer, you will be able to use your viewer normally in chrome.

0

To disable the built-in pdf viewer in the current version of Chrome, click the following within the Chrome browser window:

  1. Menu (the three dots in the top right corner of the Chrome browser window)
  2. settings
  3. advanced
  4. Content settings (under privacy and security)
  5. PDF documents
  6. Make sure that the setting "Download PDF files instead of automatically opening them in Chrome" is set to "on".

The next time you open a pdf from within Chrome, it should allow you to "always open with system viewer".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.