1

Yes, this is "similar" but not the same to this other post.

Device is MSI MS-1756 (GE70 0NC) Specs here
BIOS Ver E1756IMS.10F 12/28/2012 15:13:13
EC 1756EMS1 Ver 4.0 10/30/2013 OS Windows 7 SP1

This laptop has been a decent laptop for my wife. However about a week ago (just past the 1 y warranty) the laptop's keyboard and mouse stopped working in Windows 7. USB External keyboards and mice work fine. Keyboard works in the BIOS.

Here is the grind:

  1. Keyboard works in BIOS.
  2. Keyboard works in DOS.
  3. Keyboard works in Linux CLI.

What I have tried:

  1. "Resetting EC" unplug laptop, remove battery let set (left it for a whole day)
  2. Flash BIOS version RESET EC again.
  3. Flash EC Version.
  4. Boot without battery installed.
  5. Re-Install Windows (KB & Mouse don't even work in Windows Setup or PE)
  6. Ubuntu 13.10 LiveCD KB Doesn't work in GUI, However booting into text mode KB does (kinda).
  7. Windows 8, Tried to install and nothing..

It has something to do with ACPI, If I boot the LiveCD hit ESC then F6 select "acpi=off" then enter, then the laptop keyboard works in the Ubuntu GUI, but the trackpad doesn't.

0

One of my laptops has an unlabelled button near the trackpad that turns the trackpad on on off.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.