9

I have been using remote desktop at my office and have been using it in maximized mode, but not in full screen mode. When I press maximize, it covers the entire window but doesn't move to full screen.

Recently I formatted system and now when I maximize the window, it switches to full screen. I really don't want full screen, because I would like to be able to see my taskbar, but I want the remote desktop window maximized. Could anybody please tell me how to maximize the window without switching to full screen.

  • 1
    possible duplicate of Remote Desktop won't maximize – Ƭᴇcʜιᴇ007 Mar 5 '14 at 15:27
  • Marked dupe may seem to be (requesting) the opposite to this, but it's really the same thing with the same (although opposite) solutions. :) – Ƭᴇcʜιᴇ007 Mar 5 '14 at 15:28
  • I know it seems like a duplicate, but I have tried those solutions. When I restore the window, the window is small. When I maximize the window to make it occupy the screen completely, but it switches to full screen, and hence I cannot see my taskbar – anirudh Mar 6 '14 at 4:55
19
  1. Launch Remote Desktop Connection.
  2. Click Options and switch to Display tab.
  3. Drag the slider under Display configuration from Large (Full Screen) to one tick down.
  4. Click Connect to check the issue.
7

You can launch Remote Desktop with height and width parameters. If you set these to be slightly smaller than your display size, it will take up almost all the screen, will still show your task bar and will not display scroll bars:

Screenshot of Remote Desktop

As detailed in this answer, launch Remote Desktop with the following parameters:

/w:[width] and /h:[height]

I have a 1280 x 1024 screen size, so it works if I run the following:

mstsc.exe /w:1270 /h:960

Modify the parameters to suit your size screen, then go to Start > Run, and paste it there. Hit OK to run it. You may have to maximise the window to take up the full dimensions you have set.

Incidentally, every time you run Remote Desktop afterwards it should remember these settings without you telling it to. If it does 'forget', just save it as a shortcut and run that every time.

  • Works beautifully. I've found that windows often resets the Default.rdp file. With this solution, that isn't a problem. – primo Aug 11 '15 at 11:10
  • All these years and never knew that existed. Great tip! – RegencySoftware Apr 5 '17 at 14:02
2

Hi you can use windows shortcut option: Ctrl+Alt+Break

0

None of the other answers worked for me, I always got a vertical and horizontal scroll bar. But I also noticed that on the drop down from the RD menu "Smart Sizing" was greyed out and could not change. Some more searching and I found that I could edit the Default.rdp file with a text editor, and added the following line:

smart sizing:i:1

Now everything works as expected.

-1

I tried to fix mine- I am remoting into work through my laptop and connecting to a wide screen through HDMI. I did what the first answer said by clicking the remote desktop connector, then options arrow, the display tab. Mine was already set at full screen, so I reduce it, click okay, closed it, open again and increased it and it worked. I guess I made it refresh.

  • You should provide specific details on how you solve the problem. Your solution, if properly explained, could be helpful to the author of this question. – Ramhound Feb 23 '17 at 17:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.