2

I just installed Debian (Wheezy) on a Windows XP machine and am dual booting. But the clock is different! It's one hour late on XP versus Debian.

I'm in Paris (GMT +1) and we're in winter (daylight saving time).

I believe I set the time correctly in Debian but I'm not sure. Is it possible that Windows detects the daylight savings time and not Debian?

How to set it correctly so that I don't need to change the clock every time I change OSses?

2

I believe the problem is that Debian actually changes system lock to UTC and then adjust its display the user desired timezone. XP on the other hand changes system lock to your desired timezone.

Take a look at this answer for info how to change your Debian timezone Changing timezone on Debian keeps Local Time in UTC

  • 2
    That is correct: PC BIOSes have no concept of UTC vs local time and just store a timestamp, uninterpreted. Both OSes might be configured to interpret BIOS time as either UTC or localtime -- the Windows configuration is explained here. The only "trick" is that both dual-bootes OSes just should agree on the same interpretation. The difference is that Debian's installer defaults to UTC while Windows installer defaults to local time. – kostix Mar 6 '14 at 17:52
  • Another point of interest is that when you're setting up a virtual machine in the VirtualBox GUI, its setting for the BIOS time interpretation will depend on the selected OS flavor: for Linux it will be UTC and for Windows it will be localtime. – kostix Mar 6 '14 at 17:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.