0

I am trying to fix component store corruption on my windows 8 laptop which is preventing me from upgrading to Windows 8.1. I have tried to run DISM /online/Cleanup-image/RestoreHealth but it doesn't work because of an invalid source. My laptop came with the OEM version of windows so I don't have a installation CD. So where or how do I get a valid source to repair my corruption? Can I capture an image from a running Windows 8.1 computer that isn't corrupt? I've read the DISM articles about how do capture and image, but where should I capture a valid image from.

Here are the links to the DISM and CBS logs:

https://drive.google.com/file/d/0BxX6CIDigV64cHEtZWxGRlNaTkE/edit?usp=sharing

https://drive.google.com/file/d/0BxX6CIDigV64aFJPN1ktamNyekU/edit?usp=sharing

  • upload the DISM and CBS log files. – magicandre1981 Mar 6 '14 at 19:21
  • Do you mind if I use Google Drive? – Lars Hovden Mar 6 '14 at 20:10
  • You might be able to get a clean install iso windows.microsoft.com/en-us/windows-8/… – user993553 May 21 '15 at 18:24
  • Thanks for the info. Have a couple of other computers this will be helpful for. On my laptop I just did a factory reset and updated from scratch. I was able to install 8.1 then. – Lars Hovden Jun 10 '15 at 15:37
1

The DISM logs showed that the DISM commands have worked:

Summary: Operation: Detect and Repair Operation result: 0x0 Last Successful Step: Entire operation completes. Total Detected Corruption: 0 CBS Manifest Corruption: 0 CBS Metadata Corruption: 0 CSI Manifest Corruption: 0 CSI Metadata Corruption: 0 CSI Payload Corruption: 0 Total Repaired Corruption: 0 CBS Manifest Repaired: 0 CSI Manifest Repaired: 0 CSI Payload Repaired: 0 CSI Store Metadata refreshed: True

In this thread on the Microsoft Community forums, some users have used a Clean Boot in order to upgrade when this error message has presented itself. Another one found that the folder c:\$Windows~BT folder needed to be deleted for the upgrade to finish successfully.

Hope this helps,

0

Those logs show that there is some meta data corruption that looks to be unrepairable. That may or may not be a serious problem. Why does it block you from upgrading to 8.1? Are you unable to install the pre-req update? If so can you attempt it again and upload the CBS.log from that attempt?

  • Yes I have ensured I have the pre-req updates. I tried updating again. Before I started the update I ran wsreset.exe and made sure I had all peripherals unplugged. This time it errored out with a different code: 0Xc190010b. Here is the link to the CBS log after the update was attempted:drive.google.com/file/d/0BxX6CIDigV64QnZMNWhscFZjLVE/… – Lars Hovden Mar 7 '14 at 20:42
  • Where are you seeing the error, because there was no attempt made to install anything in that cbs.log, and there were no errors indicated? – Troy Mar 11 '14 at 7:00
  • In the Windows Store while 8.1 is downloading/installing it gets all of the way to the "Preparing to Restart Stage" and then says "This app wasn't installed." And when I view the details it says "Something happened and the Windows 8.1 couldn't be installed. Please try again. Error code: 0xc190010b". I can't think of much else besides a clean install. – Lars Hovden Mar 11 '14 at 16:17
  • Have you been able to find anything in the log that stands out? – Lars Hovden Mar 19 '14 at 12:32
0

Decided to just factory reset the computer and run updates from scratch. I was able to install the 8.1 update after this.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.