1

I installed predictive mode in emacs. After doing M-x predictive-mode I get the following error

Symbol's function definition is void: run-hook-wrapped

and I can no longer type in the buffer. Any ideas?

  • Hmmm . . . the function run-hook-wrapped is written in C and is included in a current version of Emacs Trunk -- eval.c. My best guess is that you have an old version of Emacs, or the Emacs installation has been damaged and will need to be reinstalled. My recommendation would be to upgrade your Emacs installation to the latest stable public release, or try out a snapshot developer build of the experimental version. – lawlist Mar 6 '14 at 21:15
  • Following up on what @lawlist wrote: Check the file header (Commentary) of the Predictive file(s), to see if you can find out what Emacs versions it requires. There might be, for example, a Compatibility spec in the header. If necessary, contact Toby Cubitt, the author of Predictive mode. He should be able to tell you what is minimally required. (But try first to find this info in the Predictive files.) – Drew Mar 7 '14 at 2:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.