0

I wanted to play my steam game TDU2, but after a successful install the game does not start. I mean, there is no window popping up or anything noticeable, except for the launcher that closes (normal behavior). There is no error message or log of whatever. When looking at the processes, I see testdrive2.exe appearing, then werfault.exe and then they close both. Such a thing also happened with dirt3. For TDU2 I tried to delete uplauncher.locqldb, but that did not work. Installing a nev version of DirectX tells me I already have the latest version.

of course you want to know the specs. TDU2 has run fine on windows 7, and I haven't tried dirt 3 there. I am currently:

  • running windows 8.1
  • on an Asus A75Vm-ty078v (laptop)
  • nvidia GeForce GT 630M (using the latest drivers)
  • Intel Core I7 3610QM
  • 6GB RAM

I think you need more information to help me find and eliminate the problem, so ask for that (as I do not know what is needed right now).

note: both exes (from the 2 games referenced above) do not have the compatibility tab when right clicking --> properties. The way I worked around this was right click --> solve compatibility issues and then selecting windows 7/xp both did not work on any game.

I am not afraid of using command line / regedit / etc to find/solve the problem.

other games do work:

  • nfs most wanted/rivals
  • street cleaning simulator (just for checking nvidia physx)
  • farming simulator/ski region simulator
  • spintires
  • warzone 2100
  • space engineers
  • kerbal space program

this list might help in excluding some problems, and I think it is really tdu2 related, as that is the only game acting this weird (it has not been updated as Eden is closed). If there is no solution I will try to get a legitimate windows 7 copy (as my laptop originally came with that) and put that in hyper-v (microsofts visualisation platform, 'installed' with windows 8).

EDIT:

Using the Universal Launcher from knyazev, I get the following error in the log file:

System.IO.IOException: Kan geen bestand maken dat al bestaat. //dutch for 'can\'t create a file that already exists', but I have no idea which game

   bij System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
   bij System.IO.File.Move(String sourceFileName, String destFileName)
   bij TDU2_Universal_Launcher._UL_MainWindow._UL_button_RunGame_Click(Object sender, EventArgs e)

This worked perfectly in window 7

  • did you dive into the td folder under steam/common? There should be a "redist" folder which has the required redistributable library files for use with the game. Try running those to ensure you have the proper versions installed for the game. – horatio Mar 6 '14 at 20:53
  • also, what happens if you launch the game executable directly without the launcher? Is there a 32bit/64 bit version? – horatio Mar 6 '14 at 20:55
  • @horatio I have ran all the installers from the folder, with no luck. I don't know about two different bit versions (I think it is all 32 bit for the people who have an 'old' processor). The game is not runnable by starting the game directly (testdrive2.exe). It should although be possible to run this game from a launcher someone made, and I used that successfully in the past when the school network was blocking steam. It now gives the error can't create file, detailed error in log file. I will add the error code to the question – MarijnS95 Mar 6 '14 at 21:05
0

The problem was that I was running EMET. I turned of every security setting and it worked. If other people still have problems just ask.

Currently I just turned off everything (as doing it for application only didn't work. Now I have adressed the problem and will try to find the exact thing that made the change.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.