1

We are trying to transmit a video-stream via netcat from a OpenVPN server to a client.

The server is a Raspberry Pi with Pidora running on it. The client is a Notebook with Ubuntu 12.04 and has a IPv6 connection.

OpenVPN

The Notebook is able to connect to the PI. By pinging the server/client, packages are transmitted.

Netcat

The firewall is open for port 5001.

By running:

(On Ubuntu)

nc6 -l -p 5001

(On the Raspberry)

nc6 10.8.0.6 5001

We are able to transmit text messages. Sending files by running

(On Ubuntu)

nc6 -l -p 5001 > test.txt

(On the PI)

cat test.txt | nc6 10.8.0.6

also works for small text-files (Python skript).

If we try to send pictures (.jpeg) or 2sec videos (.h264) the targeting file stays empty.


We also tried the connection to different PCs (Windows, Fedora) and this worked properly by displaying the video-stream. But they were not in the same network as the Ubuntu machine.

Any suggestions?

Thanks in advance.

UPDATE:

By setting the MTU to 1390 like here described, bigger packages could pass the tunnel and the video-stream worked.

  • Why is this tagged ipv6? There doesn't seem to be anything relevant to IPv6 here. – Michael Hampton Mar 7 '14 at 14:23
  • So it's because we connect from a IPv4 network to a IPv6 network and this maybe is some critical point. But I am not shure about it. – sembel Mar 8 '14 at 0:50
1

The problem may well be an MTU issue. Try MTU clamping or playing with mssfix and fragment options in Openvpn.

  • We played again with the MTU and we could finally get it working. I wrote an update in my question. – sembel Mar 11 '14 at 1:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.