18

I accidentally clicked Always open files of this type on a file I had downloaded and now I can't turn it off. There seems to be no option in the settings page, and files that are automatically opened don't appear in the download bar so there is no way to uncheck that option from there. Apparently, there used to be a button that would reset that setting, but it seems to have been removed as of version 33.

The <chrome root>/User Data/Default/Preferences file is a JSON file containing all Chrome settings. The following data can be found in it:

"download": {
   "extensions_to_open": "jpg",
}

I tried to solve the problem by removing the extension from the setting:

"download": {
   "extensions_to_open": "",
}

However, that didn't work. The setting was reverted to the original value shortly after. The same thing happened when I edited the file with Chrome closed, and with my Google account disconnected.

Is there any way to make Chrome stop opening files automatically?


<chrome root> refers to a path on the file system that varies depending on the opearting system.

  • In Windows

    C:\Users\<username>\AppData\Local\Google\Chrome\
    
  • In OS X

    ~/Library/Application Support/Google/Chrome/
    
  • In Linux

    ~/.config/google-chrome/
    

As pointed out, there really is a button to reset this flag. However, it does not appear in my settings page for some reason.

The button does not appear.

What could possibly be happening?

16

You can clear the auto-opening settings in the Downloads section in the Chrome settings:

enter image description here

| improve this answer | |
  • 2
    That's weird. My settings page does not have that button. I amended my question with a screenshot. What could be the problem? – Matheus Moreira Mar 7 '14 at 21:24
  • 1
    @MatheusMoreira: Huh, that's weird. Are you logged into Chrome with a Google account to sync settings? I would recommend trying to make sure that all Chrome processes are shut down (even possible background ones) and then adjusting the preferences file again. Unless you're syncing settings with a Google account, I can't imagine why it would come back. Let me know if you find out anything – Der Hochstapler Mar 7 '14 at 21:49
  • Yes, I'm logged into my Google account. At first, I tried closing down all Chrome windows and even signing out of Chrome, to no avail. I just restarted my computer for other reasons and sure enough, it was there. I suppose I forgot about the background process. Funny how "restarting the computer" never really crossed my mind. – Matheus Moreira Mar 7 '14 at 22:13
  • 1
    @MatheusMoreira: Hey, I hardly ever reboot myself :) I'm glad you were able to solve it! – Der Hochstapler Mar 7 '14 at 22:38
  • 2
    The "clear auto-opening settings" option only appears if you've set some file types to auto-open. productforums.google.com/d/msg/chrome/abV0JItj7KQ/ALP2M3Udi7YJ – JinSnow Feb 11 '17 at 9:08
1

Click Settings > Advanced Settings (at the bottom part of the page) > uncheck "Ask where to save each file before downloading" under the Downloads heading.

| improve this answer | |
0

If you have selected 'always open in adobe acrobat', you usually don't need to worry about security because Windows/Chrome will detect unsafe files.

However if you want to turn this option off, simply download a large file. I went to this link to download the aberdeen university prospectus

https://www.alphasoftware.com/alphaforum/showthread.php?117967-How-to-download-a-very-large-pdf-file

Click ALT + LINK and this file will start downloading slowly. While the download is going on, you will have to quickly open the 'options' and de-select 'always open'

| improve this answer | |
-2

If auto opening a file with google chrome while downloading happening ,just go to the downloaded file (left below of the page).click to pointer and deselect "ALWAYS OPEN FILES OF THIS TYPE".

If above option is not showing,then go to the setting /advance setting options/ clear "auto opening setting" in "Download" option.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.