0

Background
I recently moved to Linux Mint. I installed the LMDE201403 and pretty much have my environment setup. However, I need to install Git for my version control.

I have searched the internet for a number of ways to do this. I'll list the two that were recommended for LMDE201403:

  1. Use apt-get to install git-core sudo apt-get install git-core --fix-missing
  2. install git from the source (1.9.0)

Both of these fail for me. If I try to install it from the source I get a compile error because I'm missing the <curl/curl.h> headers. I have tried to install these using apt, but it fails to do so because the dependencies fail to authenticate.

If I try to install git-core through apt I also get some authentication errors.

I believe that the reason that I can't install this is because I'm missing some respositories. I don't know if this is the case and I haven't been able to find any backport or related repositories that I would need to install this.

Question(s):
How do you install git-core on LMDE201403?

Any information that helps in the process would be greatly appreciated, and if any details about error messages or my environment are needed I am ready to provide them.

Thanks for your help.

  • Did you apt-get install libcurl4-gnutls-dev libexpat1-dev gettext \ libz-dev libssl-dev as suggested by Git installation guide? – Reuben L. Mar 9 '14 at 6:26
  • Anytime I try to install dependencies through apt this is the error message that I get WARNING: The following packages cannot be authenticated! libgssrpc4 libkadm5clnt-mit8 libkdb5-7 libkadm5srv-mit8 comerr-dev krb5-multidev libgpg-error-dev libgcrypt11-dev libp11-kit-dev libidn11-dev libkrb5-dev libldap2-dev librtmp-dev libssh2-1-dev libcurl4-gnutls-dev libexpat1-dev Installing the packages without verification doesn't remedy the problem either. – Dodzi Dzakuma Mar 9 '14 at 6:29
2

LMDE is debian based, so googling of "debian WARNING: The following packages cannot be authenticated!" immediately finds excellent https://wiki.debian.org/SecureApt#How_to_find_and_add_a_key page.

Try so:

wget https://ftp-master.debian.org/keys/archive-key-7.0.asc
gpg --import archive-key-7.0.asc

Then "apt-get update" and "apt-get install --no-install-recommends git".

And if it doesn't help, try workaround:

apt-get install --allow-unauthenticated ...
  • I've been doing a bit of research and it looks like this is the cause of my problem. I don't know though. It looks like their repository server took a huge hit and now it's down. blog.linuxmint.com/?p=2582 – Dodzi Dzakuma Mar 9 '14 at 9:12
0

The "WARNING: The following packages cannot be authenticated!" means that the package-providing repository can't be authenticated, you should first try to refresh APT's repository cache(sudo apt-get udpate) to see if the issue is solved automatically, if not you should try to install/renew the GPG key of the Ubuntu repository(assuming that those packages are provided from Ubuntu) which is provided by ubuntu-keyring package.
$ sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 437D05b5 then execute sudo apt-get udpate again, verify if there's any warning messages.

  • I'm running Linux Mint Debian. I that case how do I update the keyserver? If what you say is true does this information help you any? Failed to fetch http://debian.linuxmint.com/latest/dists/testing/InRelease There are also a number of others that fail to update. I can provide them if needed. – Dodzi Dzakuma Mar 9 '14 at 7:54

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.