1

Hi I have a sandisk 16gb titanium cruzer, a bit dated but its worked like a charm for years. I partitioned it years ago to get rid of the U3 stuff as it just annoyed me and I have for a long time used it for various things like running live distros (utility distros but mostly AVs) and made heavy use of yumi so i could add multiple distros.

Anyway, at some point this drive ceased to become bootable, I have tried a variety of utilities to make it bootable and I have formatted it numerous times (fat32) but no computer (that previously were able to) now boots from this flash drive.

Is there some way to diagnose what might be wrong or perhaps my description has made the issue obvious? Any thoughts on how to make it bootable again would be appreciated!

0

Try initializing flash drive by deleting all partitions and creating a new single partition spanning whole drive. Be sure to mark new partition as bootable (active) !

FAT32 format should be preferred as you could make the partition bootable as well on BIOS as on UEFI systems.

0

Well this is not quite an answer, close though. I tried with windows disk manager and gparted and couldn't get an option to make the drive bootable. I then came across "Rufus" and gave it a try to try and make the drive bootable, it gave a warning message that there were other partitions on the drive and they might be erased, this was strange as noether gparted nor disk manager showed other partitions but I went ahead with Rufus using the "MBR partition scheme for BIOS or UEFI computers" under the "Partition scheme and target system type" option, and Viola! Now it boots?! Go figure, not quite an answer but perhaps that is enough info that someone else can formulate a complete answer?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.